Microsoft 365 Formule combinant multiples critères et OU

Wiil85

XLDnaute Nouveau
Bonjour à tous,

Je fais face à cette problématique.
Je dois déterminer le nombre de lignes par collaborateur (colonne "B") pour lesquelles je n'ai pas de numéros de téléphone (colonnes "N à P") valides.

Mes critères :
- Colonne "B" > nom du collaborateur (je peux avoir plusieurs fois le nom du même collaborateur dans la colonne "B")
- Colonne "N" > téléphone bureau
- Colonne "O" > téléphone domicile
- Colonne "P" > téléphone portable

Le résultat doit exclure les collaborateur pour lesquels j'ai au moins une des 3 champs téléphone renseigné et différent de "0".
J'ai essayé avec NB.SI.ENS mais je ne peux pas insérer la condition OU dans la formule.

En pj un extrait de mon fichier avec les colonnes concernées. Je recherche les colonnes colorées en jaune.
Merci d'avance pour vos bons conseils!
 

Pièces jointes

  • Test.xlsx
    9.3 KB · Affichages: 7

fanch55

XLDnaute Barbatruc
Bonjour,
Avec la fonction Filtre :
Affichage des formules:
1711552260648.png

Affichage normal:
1711552168590.png

et via MFC :
1711552397102.png
 

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonsoir Wiil85, et bienvenu sur XLD,
Un essai en PJ, pas très joli avec :
VB:
=SOMMEPROD((A2:A7<>"")*(B2:B7&C2:C7&D2:D7=""))+SOMMEPROD((A2:A7<>"")*(B2:B7&C2:C7&D2:D7="0"))+SOMMEPROD((A2:A7<>"")*(B2:B7&C2:C7&D2:D7="00"))+SOMMEPROD((A2:A7<>"")*(B2:B7&C2:C7&D2:D7="000"))
 

Pièces jointes

  • Test.xlsx
    9.1 KB · Affichages: 4

Discussions similaires

Réponses
13
Affichages
626
J
  • Question
Microsoft 365 Aide sur formule Excel
Réponses
2
Affichages
379
J

Statistiques des forums

Discussions
312 820
Messages
2 092 410
Membres
105 410
dernier inscrit
TahYou-K3n