XL 2016 format des nombres

ma.saouab

XLDnaute Nouveau
j'ai des nombres avec deux virgules dans une colonne et je voulais remplacer la virgule des millier par un point
 

Pièces jointes

  • fichier.xlsx
    9.1 KB · Affichages: 12

TooFatBoy

XLDnaute Barbatruc
Bonjour,

j'ai des nombres avec deux virgules dans une colonne et je voulais remplacer la virgule des millier par un point
Ne serait-il pas mieux de supprimer les virgules séparatrices de milliers, plutôt que de les remplacer par des points ?

Ainsi on obtiendrait des nombres au lieu de textes, et on pourrait les afficher au format désiré, et donc avec un séparateur de milliers aussi farfelu soit-il (point, #, *, etc.).
Mais attention si tu choisis un séparateur qui t'es propre, car apparemment tu auras alors la même loufoquerie dans tous les classeurs Excel que tu ouvriras sur ton PC.

Code:
=SI(ESTNUM(F7);F7;SUBSTITUE(GAUCHE(F7;NBCAR(F7)-3);",";"")+DROITE(F7;2)/100)
 
Dernière édition:

Discussions similaires

Statistiques des forums

Discussions
313 275
Messages
2 096 755
Membres
106 741
dernier inscrit
Dany GI