XL 2010 Extraire lettre pour ne garder que des nombres

Shpountz

XLDnaute Occasionnel
Bonjour à tous

Dans une colonne j'ai pare exemple XS-5-2-4-2-1 et je souhaiterai extraire uniquement le 5
Il peut y avoir aussi "Inédit" et dans ce cas il ne doit rien s'afficher
Je joint un petit fichier un peu plus explicatif

Merci d'avance
François
 

Pièces jointes

  • Estraire Lettre.xlsx
    8.5 KB · Affichages: 53

mapomme

XLDnaute Barbatruc
Supporter XLD
Bonsoir Shpountz, pierrejean :),

Un essai avec une formule matricielle.
S'il n'y a pas de nombre entre deux tirets, (ou au début ou à la fin), alors on n'affiche rien.

VB:
=SIERREUR(0+STXT(A2;PETITE.VALEUR(SI(ESTNUM(0+STXT(A2;LIGNE(INDIRECT("$1:"&NBCAR(A2)));1));LIGNE(INDIRECT("$1:"&NBCAR(A2))));1);CHERCHE("-";A2&"-";PETITE.VALEUR(SI(ESTNUM(0+STXT(A2;LIGNE(INDIRECT("$1:"&NBCAR(A2)));1));LIGNE(INDIRECT("$1:"&NBCAR(A2))));1))-PETITE.VALEUR(SI(ESTNUM(0+STXT(A2;LIGNE(INDIRECT("$1:"&NBCAR(A2)));1));LIGNE(INDIRECT("$1:"&NBCAR(A2))));1));"")
 

Pièces jointes

  • Shpountz- Estraire Lettre- v1.xlsx
    12.4 KB · Affichages: 44
Dernière édition:

Discussions similaires

Statistiques des forums

Discussions
312 922
Messages
2 093 660
Membres
105 779
dernier inscrit
le routier