Microsoft 365 Extraction de données : 26, 28, 36,27,56, 70

Binsid

XLDnaute Nouveau
Bonjour,

Je viens demander de l'aide à la communauté.

J'ai un ensemble de valeurs dans mon tableau.

Je voulais extraire les lignes qui contiennent les valeurs 26,28, 38, 27,56, 70 vers une autre plage ou sinon masquer les lignes qui ne remplissent pas cette série de valeurs.

J'ai pas mal fait de recherche sur internet et YouTube ainsi que sur le forum, je ne trouve pas de solution.

Je demande l'aide de la communauté.

Je vous remercie d'avance.
 

Pièces jointes

  • 26_27_70.xlsx
    13.8 KB · Affichages: 5

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonsoir Binsid,
Une idée en PJ.
En colonne V on met la formule :
VB:
=SI(NB.SI(A2:T2;26)+NB.SI(A2:T2;28)+NB.SI(A2:T2;38)+NB.SI(A2:T2;27)+NB.SI(A2:T2;56)+NB.SI(A2:T2;70)>0;"X";"")
Qui met un "X" si une ou des valeurs 26,28, 38, 27,56, 70 sont trouvées.
Ensuite il suffit dans le filtre de ne sélectionner que les "X" pour ne voir que les bonnes lignes.
 

Pièces jointes

  • 26_27_70.xlsx
    14.6 KB · Affichages: 4

Binsid

XLDnaute Nouveau
Bonsoir sylvanu

Merci beaucoup pour votre solution.

Toutefois, dans la solution cherchée il faut que la série 26, 28, 36, 27, 56, 70 soit obligatoirement présente pas une des valeurs de la serie.

il faut me faut (26 et 28 et 36 et 27 et 56 et 70) et non (26 ou 28 ou 36 ou 27 ou 56 ou 70)

Je vous remercie de votre aide.
 

Amilo

XLDnaute Accro
Bonsoir @Binsid, sylvanu, le forum,

Voici une proposition avec Power query,
Le résultat se trouve dans l'onglet "Power Query" selon la liste des nombres indiqués dans la colonne "Y"
Visiblement, aucune ligne ne comporte l'ensemble des 6 nombres de la liste

Cordialement
 

Pièces jointes

  • Binsid.xlsx
    26.6 KB · Affichages: 3

Jacky67

XLDnaute Barbatruc
Bonjour,

Je viens demander de l'aide à la communauté.

J'ai un ensemble de valeurs dans mon tableau.

Je voulais extraire les lignes qui contiennent les valeurs 26,28, 38, 27,56, 70 vers une autre plage ou sinon masquer les lignes qui ne remplissent pas cette série de valeurs.

J'ai pas mal fait de recherche sur internet et YouTube ainsi que sur le forum, je ne trouve pas de solution.

Je demande l'aide de la communauté.

Je vous remercie d'avance.
Bonjour à tous,
Il n'y aucune ligne correspondante avec 26 et 28 et 36 et 27 et 56 et 70
 

Pièces jointes

  • 26_27_70.xlsx
    31.8 KB · Affichages: 8

Binsid

XLDnaute Nouveau
Bonsoir amelio,

Je vous remercie pour votre proposition.

J'ai regardé votre proposition avec Power query, je ne comprends rien.

Je ne vois même pas le tableau d'origine.
Est-ce vous envoyé le bon fichier ?

Je vous remercie d'avance de votre retour.

Cordialement
 

Amilo

XLDnaute Accro
Re,

Le tableau d'origine se trouve au même endroit dans l'onglet "azur",
Cependant, j'ai converti la plage en un tableau structuré,

Vous pouvez faire des tests dans le tableau d'origine puis sous "Données" faites "Actualiser tout"
Et vérifiez le résultat dans l'onglet "Power Query"

Edit : bonsoir Jacky67, idem, je ne retrouve aucune ligne répondant aux critères

Cordialement
 
Dernière édition:

Discussions similaires

Statistiques des forums

Discussions
299 915
Messages
1 980 047
Membres
206 965
dernier inscrit
Mithanne