XL 2013 Erreur macro copie de cellule entre classeur

gorghrom

XLDnaute Junior
Bonjour,
J'ai une erreur que n'arrive pas à résoudre dans une macro de copie de données entre 2 classeurs :
ci joint les fichier.
je lance une première fois la macro qui fonctionne très bien. mais lorsque je lance une seconde fois cela ne marche pas. Il semble avoir un erreur dans la première copie.
En effet lorsque j'ouvre le fichier cible une erreur apparait :
1637058053333.png

en cliquant sur yes :
1637058090411.png

et en suivant le lien :
1637058134637.png


Je trouve cela curieux car sur un fichier bcp plus simple de démo, cela fonctionnait très bien.
Je ne comprend vraiment pas d'où l'erreur pourrait venir.
Sauriez vous m'aider parce là je sèche....
merci bcp par avance
 

Pièces jointes

  • 1637058048133.png
    1637058048133.png
    13.5 KB · Affichages: 19
  • ENSP - Données consolidées.xlsx
    10.3 KB · Affichages: 1
  • FR FORMULAIRE RGA.xlsm
    159.7 KB · Affichages: 1

Hasco

XLDnaute Barbatruc
Repose en paix
Bonjour,

Essayez en ne copiant QUE les valeurs. Exemple :
VB:
Sheets("UWE DATA").Range("D4").Value = ThisWorkbook.Sheets("SECTION A1").Range("D4").Value
la méthode .Copy copie tout, les données, les formats, validation, liens etc.... appliqués dans des contextes différents, ces 'extras' aux données peuvent poser problème.

Et visiblement vous n'avez besoin que de données brutes dans le transfert.

Cordialement
 
Dernière édition:

Discussions similaires

Statistiques des forums

Discussions
312 836
Messages
2 092 623
Membres
105 469
dernier inscrit
gautronmi