Compter le nombre de personnes par service

spitfire378

XLDnaute Occasionnel
Bonjour a tous, j'ai un tableau Excel contenant différents personnes associées a différents services. Est-il possible de comptabiliser le nombre de personnes par services et d'en obtenir un graphique.

Merci beaucoup d'avance.:)
 

Tibo

XLDnaute Barbatruc
Re : Compter le nombre de personnes par service

Bonjour,

Tu peux peut-être commenver à rassembler dans un nouveau tableau tes données avec la fonction NB.SI :

=NB.SI(plage_services;service_à_cacluler;effectif)

Faire alors un graphique avec ces données.

Si problème adaptation, reviens avec un bout de fichier exemple (sans données confidentielles).

@+
 

Raja

XLDnaute Accro
Re : Compter le nombre de personnes par service

Bonjour et bienvenu sur le forum,

Peux-tu nous envoyer ton fichier ? On aura plus de faciltés à te donner un coup de main. Sinon si tu veux faire comme un(e) grand(e), essaye de trier ton tableau (menu Données/trier) par services et fais des sous-totaux(menu Données/Sous-totaux) pour calculer le nombre de personnes par service. Tu peux également utiliser la module Tableau Croisé Dynamique pour ce faire.
 

Tibo

XLDnaute Barbatruc
Re : Compter le nombre de personnes par service

re,

Une idée :

En dessous de ton tableau de A18 à A29 par exemple les services 1 à 12 :

En B18 :

Code:
=NB.SI($H$2:$H$14;A18)

à recopier vers le bas

Ce nouveau tableau te donne une base pour ton graphique.

Essaye et dis nous

@+
 

spitfire378

XLDnaute Occasionnel
Re : Compter le nombre de personnes par service

J'en profite pour vous poser une grosse question : J'ai un projet, créer un outil de statistiques en VB 2005, un programme capable de récupérer des données d'une feuille excel, créer des graphiques a partir des différentes données de cette même feuille et de rassembler dans un nouveau classeur ces différents graphiques, pour pouvoir ensuite imprimer le tout. Alors tout d'abord est-ce possible? Vaut-il mieux commencer par créer mon code en VBA pour ensuite le retravailler dans VB 2005? Avez vous 2/3 idées a me faire partager pour que je puisse me lancer dans mon projet. Voila merci milles fois
 

spitfire378

XLDnaute Occasionnel
Re : Compter le nombre de personnes par service

J'ai utilisé comme vous l'expliquiait la formule NB.SI mais voila le probleme c'est que si je rentre une nouvelle personne dans mon tableau, la formule n'est pas capable d'incrémenter d'une case dans la partie plage.
 

Pièces jointes

  • Classeur1.xls
    17 KB · Affichages: 101
  • Classeur1.xls
    17 KB · Affichages: 99
  • Classeur1.xls
    17 KB · Affichages: 99

JCGL

XLDnaute Barbatruc
Re : Compter le nombre de personnes par service

Bonjour à tous,

Que des noms de ville que je connais bien :),

Un essai avec un NB.SI() et une plage nommée.

Teste un rajoutant des services dans les cellules bleues

A++ ami bas-normand ;)

A+ à tous
 

Pièces jointes

  • Essai 1.zip
    7 KB · Affichages: 63
  • Essai 1.zip
    7 KB · Affichages: 63
  • Essai 1.zip
    7 KB · Affichages: 68
Dernière édition:

Discussions similaires

Statistiques des forums

Discussions
312 895
Messages
2 093 383
Membres
105 714
dernier inscrit
POKITO