calendrier dont les jours reste en place

devileyes

XLDnaute Junior
Bonjour le forum,

Voilà en fait j'ai un fichier avec un calednrier 12 signet pour chaque mois, en fait 'jaimerais bien que lorsque je mets l'année en A2 que toute mes feuilles change automatiquement (sans VBA SVP merci) mais j'aimerais que les jours (Lundi, Mardi ,mercredi , jeudi,etc...) reste a la meme place mais que uniquement les dates changent lorsque je change d'année.

Est-ce possible?

Un grand merci d'avance pour toutes vos solutions

toujours sans VBA
j'espere qu'un jour il nous debloque ces macros car ils commencent a bien faire les boss :) :) :) ;)

Je joint un fichier comme apercu (la date devrais se trouver en-dessous du jour)
[file name=CalendrierV1.zip size=7536]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/CalendrierV1.zip[/file]
 

Pièces jointes

  • CalendrierV1.zip
    7.4 KB · Affichages: 12
  • CalendrierV1.zip
    7.4 KB · Affichages: 12
  • CalendrierV1.zip
    7.4 KB · Affichages: 11

andré

XLDnaute Barbatruc
Salut Christophe,

J'avais déjà vu ton fichier en début d'après-midi.
Il me semblait bien avoir une réponse, mais un peu usine à gaz.
Je m'étais donc dit qu'en patientant quelque peu je trouverais une réponse toute faite, ce qui m'aurait appris d'apprendre quelque chose (lol).

Mais non, silence complet !

Si tu n'as pas de réponse avant demain matin, je mettrai la mienne au point.

En attendant, bonne soirée.
Â+
 

Bebere

XLDnaute Barbatruc
bonjour Devileyes,André

j'ai fait le 1er mois
à toi de voir pour la suite
si problème, reviens nous
à bientôt
[file name=CalendrierV1_20051007174914.zip size=9746]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/CalendrierV1_20051007174914.zip[/file]
 

Pièces jointes

  • CalendrierV1_20051007174914.zip
    9.5 KB · Affichages: 18

andré

XLDnaute Barbatruc
Salut Bebere,

C'est exactement la solution que j'envisgeais, mais il me semblait qu'il devait y avoir plus simple.

Ce que je n'étais pas parvenu à résoudre c'était de maintenir les mois en majuscules, tout en pouvant se servir de cette donnée pour la suite.

Je vois que toi non plus, mais c'est un détail !

Attendons, car il me semble qu'il doit y avoir plus simple.
Â+
 

Bebere

XLDnaute Barbatruc
re
j'ai encore un peu de temps et c'est mon jour de bonté(lol)
la suite vient de me venir à l'esprit
1-tu sélectionnes la feuille janvier(coin gauche entre 1 et a)
copier
2-tu actives l'onglet février
3-tu actives l'onglet décembre tout en appuyant sur la touche
majuscule(flèche vers le haut)
et coller
je vérifie demain,si problème nouvel envoi
un bonjour de belgique(tongres) à André
à bientôt :)
 

Monique

Nous a quitté
Repose en paix
Bonjour,

Tu as une feuille à part pour saisir le n° de l'année.
Les fériés se mettent automatiquement à jour.

En A3 de chaque feuille,
une formule extrait le nom de l'onglet
et te donne (valeur numérique) la date du 1er du mois, format mmmm
(les mois sont en minuscule, pourquoi majuscule ?)
Ne pas oublier un accent en février, août et décembre.

Ensuite, formule conditionnelle pour avoir le 1er lundi dans la bonne cellule.
Formule conditionnelle pour ne pas avoir les dates du mois suivant.
(j'ai ajouté des lignes, il manquait 1 semaine si le mois commence une sam ou un dim et fait 30 ou 31 jours)

Format conditionnel pour avoir les fériés en couleur (hors samedi dimanche)

Je n'ai laissé que 3 ou 4 mois pour alléger,
mais une fois que tu es sûr du bon fonctionnent d'une feuille,
tu la dupliques, tu changes le nom de l'onglet et ça marche.
[file name=CalendDevileyes.zip size=9463]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/CalendDevileyes.zip[/file]
 

Pièces jointes

  • CalendDevileyes.zip
    9.2 KB · Affichages: 25

devileyes

XLDnaute Junior
salut Monique,André,bebere et forum,

Je vous remercie a otus les trois de vous êtes pencher sonmon problème.

comme je vois comme d'habitude des réponses rapide et bien sympathique et toujours des solutions a tout vous est trop super

merci beaucoup

la solution de Monique me conviens parfaitement celle de bebere est super aussi.

désoler pour bebere mais merci quand meme de t'etre pencher sur le problème

merci aussi a andré

vous êtes trop génial tous

merci merci merci mile merci :silly: :silly:
 

Monique

Nous a quitté
Repose en paix
Bonjour,

Dans la feuille des fériés, il y a une plage de dates,
nommée 'Artt'
Dans la mise en forme conditionnelle des feuilles mensuelles,
il y a une condition en plus :
=ET(A5<>'';NB.SI(Artt;A5)>0)
[file name=CalendDevileyesV1.zip size=8554]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/CalendDevileyesV1.zip[/file]

Message édité par: monique, à: 07/10/2005 21:19
 

Pièces jointes

  • CalendDevileyesV1.zip
    8.4 KB · Affichages: 25
G

Gilbert

Guest
Bonsoir le forum, Monique
Je reviens vers toi car je ne comprends pas ce qui se passe dans le calendrier adapté à mes besoins, le mois de MAI me pose problème.
Veux-tu bien m'expliquer d'où vient l'erreur.
En te remerciant par avance.
 

Monique

Nous a quitté
Repose en paix
Bonjour,

Je viens d'essayer le mois de mai, sur 28 ans : ça marche
Il ne faut pas de faute d'orthographe au nom du mois
(pas facile d'écorcher le mois de mai)
On peut même mettre des espaces avant et après, Excel est d'accord.
 
G

Gilbert

Guest
Regarde STP [file name=AgendaMensuel.zip size=15352]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/AgendaMensuel.zip[/file]
 

Pièces jointes

  • AgendaMensuel.zip
    15 KB · Affichages: 14

Monique

Nous a quitté
Repose en paix
Re,

Tu démarres en colonne B, c'est pour ça.

En B5 :
=SI(JOURSEM($B$3;2)=COLONNE()-1;$B$3;'')

En C5 :
=SI(B5<>'';B5+1;SI(JOURSEM($B$3;2)=COLONNE()-1;$B$3;''))

Joursem(un lundi quelconque; 2) = 1
Colonne(B5) = 2
Colonne(B5) -1 = 1, comme un lundi

Message édité par: monique, à: 08/10/2005 22:23
 

Discussions similaires

Statistiques des forums

Discussions
312 946
Messages
2 093 830
Membres
105 848
dernier inscrit
toooom