XL 2010 calcul SommeProd avec Gauche

llulu24

XLDnaute Nouveau
Bonjour,

j'essaye de faire un calcul avec la fonction SommeProd et la Fonction Gauche mais sur plusieurs nombres (de 121 à 129) , mais impossible de trouver la solution.
=SOMMEPROD(('2017'!$Z:$Z="MA")*('2017'!$L:$L=1)*('2017'!AD:AD="IS")*(GAUCHE('2017'!$S:$S;3="12*")))

Merci pour votre aide
 

JCGL

XLDnaute Barbatruc
Bonjour à tous,

SOMMEPROD() n'admet pas les colonnes entières et il manque une parenthèse sur la fonction GAUCHE.

Code:
=SOMMEPROD(('2017'!$Z$1:$Z$500="MA")*('2017'!$L$1:$L$500=1)*('2017'!$AD$1:$AD$500="IS")*(GAUCHE('2017'!$S$1:$S$500;3)="12*"))

A+ à tous
 

llulu24

XLDnaute Nouveau
sa marche , j'ai même modifié la formule en : =SOMMEPROD(('2017'!A2:A400="B")*('2017'!L2:L400=1)*('2017'!AD2:AD400="IS")*('2017'!S2:S400=128))
cette formule me renvoi 1 , alors que j'ai 10"B" , 10"1", 1"IS" et 2"128" donc pour moi la réponse et bonne
donc comment calculer tous les 120 (120 à 129) dans la même formule
 

Discussions similaires

Réponses
5
Affichages
297
Réponses
1
Affichages
253

Statistiques des forums

Discussions
312 875
Messages
2 093 147
Membres
105 639
dernier inscrit
crobyx