XL 2016 Calcul de marge en % en fonction de la valeur d'une cellule

marc.gilliand

XLDnaute Occasionnel
Bonjour,
Dans le fichier je souhaite qu'excel calcule automatiquement la valeur en colonne I en fonction de la valeur de la colonne H, à savoir :
si le prix en colonne H est de 0.00 à 30.00, le calcul est + 28% (/0.72)
si le prix en colonne H est de 30.05 à 39.95, le calcul est + 25% (/0.75)
si le prix en colonne H est plus grand que 40.00, le calcul est + 23% (/0.77)

Merci d'avance de votre aide.
 

Pièces jointes

  • Suttero_Forum.xlsx
    11.9 KB · Affichages: 3

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Marc,
En PJ un essai avec :
VB:
=SI(H2>=40;1.23*H2;SI(H2>=30.05;1.25*H2;1.28*H2))
Je fais le calcul avec la valeur initiale augmentée du pourcentage.
S'il fallait juste faire le pourcentage alors c'est le second tableau avec :
Code:
=SI(H10>=40;0.23*H10;SI(H10>=30.05;0.25*H10;0.28*H10))
car votre demande n'est pas très claire : + 28% veut il dire 28% du prix ou Prix+28% prix ?
 

Pièces jointes

  • Suttero_Forum.xlsx
    12.2 KB · Affichages: 3

marc.gilliand

XLDnaute Occasionnel
Bonjour Marc,
En PJ un essai avec :
VB:
=SI(H2>=40;1.23*H2;SI(H2>=30.05;1.25*H2;1.28*H2))
Je fais le calcul avec la valeur initiale augmentée du pourcentage.
S'il fallait juste faire le pourcentage alors c'est le second tableau avec :
Code:
=SI(H10>=40;0.23*H10;SI(H10>=30.05;0.25*H10;0.28*H10))
car votre demande n'est pas très claire : + 28% veut il dire 28% du prix ou Prix+28% prix ?
Bonjour,
Merci de votre formule. En fait, c'est si la valeur en H est soit :
de 0.00 à 30.-- il faut appliquer un 28% sur cette valeur ou divisé cette valeur par 0.72
de 30.05 à 39.95, il faut appliquer un 25% sur cette valeur ou divisé cette valeur par 0.75
de 40.00 à plus, il faut appliquer un 23% sur cette valeur ou divisé cette valeur par 0.77

Est-ce plus clair ?
De plus, est-il avec une MFC, mettre en couleur (donc 3 couleurs) chaque cellule étant impactée par une de ces trois règles. Je ne sais pas comment écrire la formule dans la MFC.
Merci de votre aide.
 

Discussions similaires

Statistiques des forums

Discussions
299 728
Messages
1 978 781
Membres
206 390
dernier inscrit
patcaudron62