aide sur message d'erreur #N/A

raym1313

XLDnaute Occasionnel
bonjour a tous
et merci pour votre aide sur RECHERCHEV

lorsque j'execute ma recherche

=+SI('P2-C1'!D1=" ";" ";RECHERCHEV(E5;'P2-C1'!A$5:B$12;2;0))

ma formule ci-dessus fonctionne parfaitement
par contre lorsque la fonction RECHERCHEV ne trouve pas E5 dans
la plage A$5:B$12 elle m affiche #N/A
ca qui est je pense normal

je souhaiterai que ce #N/A qui apparait sur mon tableau
soit effacer, sans effacer ma formule :confused:

cordialement
raymond :)
 

Tibo

XLDnaute Barbatruc
Re : aide sur message d'erreur #N/A

Bonjour raymond,

Le fait que #N/A apparaisse est dû au fait que la valeur cherchée n'est pas présente dans ton tableau.

On peut alors résoudre le problème ainsi :

Code:
=SI('P2-C1'!D1=" ";" ";[COLOR=blue]SI(NB.SI(A$5:A$12;E5)=0;"";[/COLOR]
RECHERCHEV(E5;'P2-C1'!A$5:B$12;2;0)))

Consiste à tester si la valeur E5 est présente dans A5:A12


Une autre solution consiste à tester si la formule retourne justement #N/A :

Code:
=+SI('P2-C1'!D1=" ";" ";[COLOR=blue]SI(ESTNA(RECHERCHEV(E5;'P2-C1'!A$5:B$12;2;0));"";[/COLOR]
RECHERCHEV(E5;'P2-C1'!A$5:B$12;2;0)))

@+
 

Discussions similaires

Statistiques des forums

Discussions
311 997
Messages
2 084 452
Membres
102 579
dernier inscrit
JLB35