XL 2010 #N/A sur RechercheV

LEIYAZ

XLDnaute Nouveau
Bonjour,

Je rencontre un problème sur une RechercheV qui me retourne #N/A.

La valeur recherchée (exemple 30 en M16 dans le tableau joint) est issue d'une formule. Lorsque je fais ma rechercheV avec la valeur obtenue par la formule, j'obtiens #N/A mais lorsque je note directement 30 dans la cellule, la rechercheV fonctionne.

Les cellules sont au même format, je ne comprends pas pourquoi la RechercheV ne fonctionne pas.

Pourriez-vous m'aider ?

En vous remerciant par avance,
 

Pièces jointes

  • Demandes Prestations Interprétariat Présentiel 2021.xlsb
    125.3 KB · Affichages: 11
Solution
Bonjour Leiyaz,
Essayez :
VB:
=RECHERCHEV(ENT([NB Min]); Index_Durée_Tarifs!$B$2:$C$205; 2; 0)*(1+[Majoration])
En M16 il n'y a pas exactement 30.
Si vous faites dans une cellule =M16-30 vous trouverez 5,32907E-14.
Je ne suis pas allé plus loin. très surement un arrondi ou une limite de résolution d'excel qui est limité à 15 décimales.
Ici très surement dû au temps qui sont en décimale tronqués à 15 décimales. Il faut donc prendre la partie entière pour être tranquille.
( par ex 0h30 vaut 0,0208333333333334 alors qu'en réalité il vaut 0,020833333333333333333.... )

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Leiyaz,
Essayez :
VB:
=RECHERCHEV(ENT([NB Min]); Index_Durée_Tarifs!$B$2:$C$205; 2; 0)*(1+[Majoration])
En M16 il n'y a pas exactement 30.
Si vous faites dans une cellule =M16-30 vous trouverez 5,32907E-14.
Je ne suis pas allé plus loin. très surement un arrondi ou une limite de résolution d'excel qui est limité à 15 décimales.
Ici très surement dû au temps qui sont en décimale tronqués à 15 décimales. Il faut donc prendre la partie entière pour être tranquille.
( par ex 0h30 vaut 0,0208333333333334 alors qu'en réalité il vaut 0,020833333333333333333.... )
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

Le résultat de NB min est "30,0000000000001"
Comme tu recherches une valeur exacte avec la fonction recherchev(), cela retourne une erreur.
J'ai modifié la formule en "M16" pour retourner simplement l'entier de la multiplication [DUREE]*1440

Edit: Bonjour Sylvanu:), Jocelyn:)

Apparemment ma solution ne lui plait pas 😢 .


JHA
 

Pièces jointes

  • Demandes Prestations Interprétariat Présentiel 2021.xlsb
    113.5 KB · Affichages: 7
Dernière édition:

Jocelyn

XLDnaute Barbatruc
Bonjour le Forum,
Bonjour LEIYAZ,

a tester en M16 mettre cette formule a la place de la tienne car la 13 ieme décimale de la valeur de M16 donne un 1 tu n'as donc pas exactement 30

=SI(ESTVIDE([HEURE DE FIN]); ""; ARRONDI([DUREE]*1440;0))

Cordialement

EDIT : Bonjour Sylvanu, JHA
 

Statistiques des forums

Discussions
300 889
Messages
1 988 142
Membres
210 082
dernier inscrit
bernard.dufaure.47@gmail.