Microsoft 365 Aide formule Excel

FLAM04

XLDnaute Nouveau
bonjour

la formule Excel suivante ne fonctionne qu'en partie: =SI(I3>=J3;"";SI(J3="-";30;SI(J3>=1;(J3-I3)*H3))).

ce qui n est pas pris en compte c 'est le fait que si la colonne I est inferieur à la Colonne J alors "-". Je pense que ça rentre en contradiction le fait que J soit > ou égale à 1.

Je ne sait du coup pas comment faire pour que tout fonctionne correctement.

Merci pour votre aide
 

djidji59430

XLDnaute Barbatruc
Bonjour à tous,

toutes la formules, la tienne comprise, commencent par
=SI(I3>=J3;"";
or tu dis :

" si I3 est supérieur J3 il y a toujours une valeur ( négative) qui s'affiche"

Ce qui est logiquement impossible

a mon avis, j3 est en texte.

Crdlmt
 

Franc58

XLDnaute Occasionnel
bonjour

la formule Excel suivante ne fonctionne qu'en partie: =SI(I3>=J3;"";SI(J3="-";30;SI(J3>=1;(J3-I3)*H3))).

ce qui n est pas pris en compte c 'est le fait que si la colonne I est inferieur à la Colonne J alors "-". Je pense que ça rentre en contradiction le fait que J soit > ou égale à 1.

Je ne sait du coup pas comment faire pour que tout fonctionne correctement.

Merci pour votre aide
Salut, à tester: =SI.Multiple(I3<J3;"-";J3="-";30;J3>=1;(J3-I3)*H3)
 

Statistiques des forums

Discussions
313 281
Messages
2 096 782
Membres
106 748
dernier inscrit
Abdel93