une recherche deux résultats

ixell

XLDnaute Nouveau
Bonjour à tous,
je galere depuis longtemps, alros j'ai décidé de faire appel à vos lumières :confused:
J'ai tout une base de conteneurs avec plusieurs mouvements (un conteneur peux avoir plusieurs mouvements mais pas le même mouvement).
Par ex, pour ECMU1, j'ai "entrée" à une date donnée et "sortie" à une autre date.
De l'autre coté, afin de controler certaine facture, j'ai effectué une recherchev afin de me remonter les mvt. mais la formule ne me remonte que le premiers mouvement trouvé.
Dans l'ex, le résultat de ma formule ne me remonte que deux fois "entrée".
Enfin, si le conteneur est "entrée" mais pas encore "sortie", je voudrais savoir s'il y a là aussi un moyen de le savoir :cool:
Pouvez voous m'aider ?
merci bcp !
ixell
 

ixell

XLDnaute Nouveau
Re : une recherche deux résultats

slt papou,
en PJ deux fichiers d'exemple
merci !
ixell
 

Pièces jointes

  • FICHIER BASE.xls
    13.5 KB · Affichages: 38
  • FACTURE.xls
    13.5 KB · Affichages: 47
  • FICHIER BASE.xls
    13.5 KB · Affichages: 37
  • FACTURE.xls
    13.5 KB · Affichages: 46
  • FICHIER BASE.xls
    13.5 KB · Affichages: 43
  • FACTURE.xls
    13.5 KB · Affichages: 46

Tibo

XLDnaute Barbatruc
Re : une recherche deux résultats

Bonjour,

En supposant tes données triées,

une tentative en D2 avec :

Code:
=SI(NBVAL(DECALER('[FICHIER BASE.xls]Feuil1'!$B$1;0;1;NB.SI(
'[FICHIER BASE.xls]Feuil1'!$B:$B;B2)))<NB.SI($B$2:B2;B2);"Pb";INDEX(DECALER(
'[FICHIER BASE.xls]Feuil1'!$B$1;0;1;NB.SI('[FICHIER BASE.xls]Feuil1'!$B:$B;B2));
NB.SI($B$2:B2;B2)))

à recopier vers le bas

Je te laisse tester

@+
 

Discussions similaires

Statistiques des forums

Discussions
312 848
Messages
2 092 787
Membres
105 534
dernier inscrit
EmilieG60