Trouver la colonne contenant la plus grande somme

zac.dubeau

XLDnaute Nouveau
Bonjour,

Je cherche une formule sans passer par une macro et sans faire des sous-totaux en bas de chaque colonne, qui me permette de trouver la colonne contenant la somme la plus importante et me donner la valeur de cette somme.
J'arrive pas a faire avec les formules sommeprod et max.

Merci
 

Pièces jointes

  • Classeur2.xlsx
    8.8 KB · Affichages: 56

mutzik

XLDnaute Barbatruc
bonjour
upload_2017-2-3_14-32-5.png
 

ERIC S

XLDnaute Barbatruc
Pas de solution miracle mais imagine que tu utilises une colonne vide exemple L dans ton fichier
en L5 tu écris
Code:
=SOMME(DECALER($B$5;0;LIGNES($K$5:$K5)-1;1000;1))
tu tires vers le bas du nb de colonnes à analyser

en K4 tu cherches ton max de K5 à .......
 

ERIC S

XLDnaute Barbatruc
Pas dans mes cordes toujours....

En fait une formule devrait travailler en matriciel car elle aurait les sommes intermédiaires à calculer et ensuite chercher le max.
Avec un grand nombre de données, pourrait tout ralentir.
Moi, faire les sommes sur une autre feuille (puis éventuellement masquer la feuille) me semble raisonnable : dans 6 mois cela restera facile à comprendre

Désolé, pas mieux
 

job75

XLDnaute Barbatruc
Bonjour à tous,

Il faut utiliser la fonction SOUS.TOTAL en matriciel, formules en B2 et B3 :
Code:
=MAX(SOUS.TOTAL(9;DECALER(B5:E7;;COLONNE(B5:E7)-COLONNE(B5);;1)))
Code:
=SUBSTITUE(ADRESSE(1;EQUIV(B2;SOUS.TOTAL(9;DECALER(B5:E7;;COLONNE(B5:E7)-COLONNE(B5);;1));0)+COLONNE(B5)-1;4);1;)
toutes deux à valider par Ctrl+Maj+Entrée

Fichier joint.

A+
 

Pièces jointes

  • Colonne max(1).xlsx
    16.4 KB · Affichages: 47

Discussions similaires

Réponses
6
Affichages
256

Statistiques des forums

Discussions
312 811
Messages
2 092 307
Membres
105 347
dernier inscrit
VLEN