tranformation sec en min,sec????

E

elbarto

Guest
bonjour à tous,

je cherche à transformer un temps exprimé en seconde vers un temps exprimé sous la forme xx'xx"xx.

donc en gros comment passer de 432 secondes en 7min 12sec 00.

merci à tous et bonne journée
elbarto
 
E

elbarto

Guest
derniere petite kestion

salut à vous 2,

j'ai essayé les formules mais j'ai juste un problème.

si mon chiffre a des virgules, la solution de chris ne marche plus.
la solution d'andré ne permets pas de mettre au delà des secondes.

comment faire pour faire apparaitre les dizaines de secondes apres le secondes xx"xx'xx.

merci @ vous 2

elbarto
 
A

andré

Guest
Re: derniere petite kestion

la réponse à ta kestion ne m'est pas konnue, à première vue du moins.
j'essaierai d'arrondir vers le bas le nombre intial, puis de le transformer en jj:hh:mm:ss.
ensuite, j'extrairai le deux derniers chiffres de ton nombre (fonction texte droite;nombre;2).
ce deux chiffres ne doivent pas être transformés puisque je suppose qu'ils sont déjà exprimés en centièmes.
ensuite il y a lieu de coller les deux résultats obtenus dans une même cellule.
je ne l'ai jamais fait et devrais moi-même chercher après la procédure.
peut-être que chris ou stephane pourront t'aider à résoudre ce dernier point.
il m'intéresse aussi !

andré
 
E

elbarto

Guest
j'ai trouvé une solution...

voilà,
j'y connais pas grand chose dans les formules excel,
mais en faisant des petits calculs mathématiques voilà ce ke j'ai trouvé :

j'ai transformé une cellule du type xx'xx"xx en format chiffre.
apres j'ai fait des produits en croix et j'ai trouvé une constante ki est 86394.


à koi ça sert me direz vous???
bah si je veux transformer 432 en xx'xx"xx,
je divise 432 par 86394 et ke je mette la cellule sous forme xx'xx"xx et bien ça marche!!??!!
et j'obtiens les dizaines de secondes donc 7"12',13

je pense kil y a une formule plus juste mais bon voilà.

@+ et bonne journée
 
C

chris

Guest
Bizzarre ta solution car il y a 86400 secondes par jour et la fonction temps est basée sur la journée.

Avec mon approche avec la valeur en A1
=ENT(A1/60)&"mn "&ENT(MOD(A1;60))&"sec " & ARRONDI((A1-ENT(A1))*10;0)

Avec l'approche d'André (plus juste) :
=TEXTE(TEMPS(25;;A1);"hh:mm:ss")&TEXTE((A1-ENT(A1))*10;" #")
Chris
 

Discussions similaires

Statistiques des forums

Discussions
303 475
Messages
2 011 477
Membres
219 000
dernier inscrit
flaplace