Microsoft 365 Somme verticale et horizontales

JVOS

XLDnaute Junior
Bonjour
Je souhaite faire une somme en verticale et horizontale en fonction de 2 critères avec des données récupéré à partir d'un logiciel comptable.
J'utilise la fonction SOMMEPROD
Il y a un problème dans les données que je récupère (colonnes D à L)
Les cellules vides contiennent quelque chose qui empêche l'exécution de la formule
Et impossible de trouver
 

Pièces jointes

  • Test sommesi.xlsx
    15.3 KB · Affichages: 8

JVOS

XLDnaute Junior
Bonjour à tous,

A essayer
VB:
=SOMMEPROD(($D$3:$L$3=$B$14)*($A$4:$A$7=$A15)*(SUBSTITUE($D$1:$L$1;"S";"")=$B15);$D$4:$L$7)

JHA

Bonjour, merci pour ta réponse
Le problème provient des cases vides dans la matrice $D$4:$L$7, qui ne sont pas vraiment vide
J'ai essayé de remplacer le vide par 0 avec =SIERREUR(CNUM(N4);0)
et ca fonctionne
Merci beaucoup
 

Pièces jointes

  • Test sommesi.xlsx
    16 KB · Affichages: 1

Discussions similaires

Statistiques des forums

Discussions
303 820
Messages
2 014 415
Membres
219 921
dernier inscrit
pascal77500