XL 2016 =SOMME Pourquoi ca ne marche pas

Noé71410

XLDnaute Nouveau
Bonjour a tous,
Voilà, j'ai fais une extraction d'un logiciel pro pour analyse de parc VH.
J'ai déjà dissocier tous les VH en différentes colonnes qui, pour chacune a l'immatriculation et le coût des réparations.
Je rencontre un problème qui me bloque.... quand je vais en dernière ligne de chaque colonnes pour faire la somme, celle-ci ne fonctionne pas ou ne prend qu'une partie en compte.
J'ai fais Ctrl+m pour tout passer en monétaire mais cela ne change rien.
SOMMEPROD fais le boulot, mais j'aimerais comprendre d'où viens le problème.

Autre chose, je souhaiterais qu'une fois les totaux effectués, que ceux ci aillent directement dans un autre tableau en compagnie de leurs immatriculation respectives de façons automatique... Tableau se trouvant dans une autre feuille du classeur.

Merci a vous pour votre temps passer à aider de bon débutants comme moi ^^'
 

Pièces jointes

  • TEST.xlsx
    62.1 KB · Affichages: 8

chris

XLDnaute Barbatruc
Bonjour

Une partie de tes lignes est en texte

Il suffit d'enlever l'alignement forcé à droite pour que ces "valeurs" texte se recadrent à gauche et soient repérables

Déguiser un texte en format monétaire ne change pas sa nature de texte comme l'habit ne fait pas le moine
 

chris

XLDnaute Barbatruc
Re

As-tu lu attentivement ce que j'ai écrit ?

Tu peux mettre une robe : tu ne deviens pas une femme
1652946665826.png
 

Noé71410

XLDnaute Nouveau
Re

As-tu lu attentivement ce que j'ai écrit ?

Tu peux mettre une robe : tu ne deviens pas une femme
Regarde la pièce jointe 1139972
Ok, compris!
Donc toutes les cellules qui se décales sont en fait en "texte"? Et comment faire pour toutes les repasser en monétaire. Parce que du coup je ne peux toujours pas faire mes sommes...

Et pour ma seconde demande, auriez-vous quelque chose a me proposer?
 

job75

XLDnaute Barbatruc
Bonjour Noé71410, chris,

Pour faire la somme des valeurs textes il faut les convertir en nombres (avec -- par exemple).

Après avoir ôté le caractère de code 160 (séparateur de milliers).

Formule en C138 :
Code:
=SOMMEPROD(--SUBSTITUE(C2:C137;CAR(160);))
Concernant le 2ème problème il n'a pas de sens puisque les totaux n'ont pas d'immatriculation.

A+
 

Pièces jointes

  • TEST(1).xlsx
    59.5 KB · Affichages: 5

Discussions similaires

Réponses
6
Affichages
747

Statistiques des forums

Discussions
312 930
Messages
2 093 717
Membres
105 794
dernier inscrit
mallet