Sommation sélective dans des colonnes

zeta1083

XLDnaute Nouveau
Bonjour à tous,
Voici un problème que je n'arrive pas à résoudre:
- par exemple, dans une colonne de 10 lignes, j'encode des lettres A, B, C, ou D.
- la 11ième ligne devrait contenir automatiquement le total des lettres A
- la 12ième ............................................................................. B
- la 13ième ............................................................................. C
- la 14ième ............................................................................. D
J'utilise Excel 2003.
Qui peut m'aider?
Grand merci d'avance.
 

JHA

XLDnaute Barbatruc
Re : Sommation sélective dans des colonnes

Bonsoir Zeta, le forum,

Pour compter le nombre de lettres dans une plage, utilise NB.SI()

=NB.SI(A1:A10;"A")

Edit: Oups trop tard; bonsoir bhbh
ou =SOMMEPROD((A1:A10="A")*1)

JHA
 
Dernière édition:

jeanpierre

Nous a quitté
Repose en paix
Re : Sommation sélective dans des colonnes

Bonsoir zeta1083 et Bienvenue sur le forum XLD,

Avec : = NB.SI(ta plage;"A") en A11 par exemple (ta plage, ici, serait A1:A10

soit NB.SI(A1:A10;"A")

Pareil en dessous pour B : NB.SI(A1:A10;"B"), etc....

A te lire.

Jean-Pierre

Edit : Bonsoir à tous, cartonnent les jeunes....
Re édit : et Monique pour boucler la boucle... Bonsoir à toi
 
Dernière édition:

Monique

Nous a quitté
Repose en paix
Re : Sommation sélective dans des colonnes

Bonjour,

Les lettres que tu veux compter en C1, D1, E1, F1
En C2 :
=NB.SI($A$2:$A$10;C$1)
et copier-coller vers la droite

Ou bien la lettre à compter est dans la formule :
=NB.SI($A$2:$A$10;"A")
 

zeta1083

XLDnaute Nouveau
Re : Sommation sélective dans des colonnes

Bonjour bhbh,
Incroyable! Question à peine posée, directement résolue! Grand grand merci. C'est la premi!re fois que j'expérimente une réponse si rapide sur un forum. Encore merci bhbh et le forum excel-download
 

Discussions similaires

Réponses
20
Affichages
1 K
Réponses
4
Affichages
283

Statistiques des forums

Discussions
312 113
Messages
2 085 426
Membres
102 887
dernier inscrit
MarcVeretz