Microsoft 365 Si une cellule est vide faire ressortie la valeur d'une autre cellule

Diiiloe

XLDnaute Nouveau
Bonjour à tous,
Nouvellement membre, j'essaie de me former seule sur l'outil qu'est EXCEL !
Actuellement je cherche une formule qui appliquerait la règle : si ma cellule A1 est vide, alors afficher la valeur de la cellule B1, si B1 est vide, alors afficher la valeur de C1, si C1 est vide...... etc jusqu'à la colonne E
J'ai tenté un =SI(A1="";"";MAX(A1:E1)) , ca fonctionne mais ce n'est pas ce que je recherche étant donné qu'il s'agit d'un fichier de facturation, le MAX m'affiche la valeur la plus haute entre A et E, et ce n'est pas ce que je veux car la valeur de la colonne D peut être supérieure à celle de la colonne E par exemple...

Si qqun a une solution je suis preneuse et vous en remercie d'avance !
Bonne journée,
Elodie
 

mapomme

XLDnaute Barbatruc
Supporter XLD
Re,

Suite à la remarque de @job75, pour que ça fonctionne indifféremment avec des nombres ou du texte, je reviens moi aussi aux formules matricielles :

La première valeur : =SIERREUR(INDEX(B4:F4;EQUIV(1;--(B4:F4<>"");0));"")

La dernière valeur : =SIERREUR(INDEX(B4:F4;EQUIV(2;SI(B4:F4<>"";1)));"")

Bonne-nuit à tous 🥱😴.
 

Pièces jointes

  • diiiloe- prem et der- v2.xlsx
    38.5 KB · Affichages: 0

job75

XLDnaute Barbatruc
Bonjour Diiiloe, mapomme, le forum,

Voici 2 autres formules matricielles en I4 et J4 qui fonctionnent sur des nombres ou des textes :
Code:
=SIERREUR(INDEX(B4:F4;EQUIV(VRAI;B4:F4<>"";0));"")
Code:
=SIERREUR(INDEX(B4:F4;EQUIV(0;LN(B4:F4<>"")));"")
A+
 

Pièces jointes

  • diiiloe_excel forum2.xlsx
    44 KB · Affichages: 0

Discussions similaires

Réponses
9
Affichages
297

Membres actuellement en ligne

Statistiques des forums

Discussions
313 310
Messages
2 097 037
Membres
106 816
dernier inscrit
Garry972