XL 2016 si et

richardlion

XLDnaute Occasionnel
Bonjour a tous

je souhaiterai pourvoir utiliser la formule si et avec pour une colonne des chiffres et dans l'autre des lettres

dans ma colonne N je voudrais ma reponse en fonction de la colonne K si 2 ou autre et colonne L Nice ou autre
je reste a votre disposition
 

Pièces jointes

  • SI ET.xlsx
    8.8 KB · Affichages: 5

Bernard_XLD

XLDnaute Barbatruc
Membre du Staff
Bonjour richardlion, le forum

Vite fait ! vous avez des espaces qui trainent dans votre colonne L et des nombres en texte qui trainent dans votre colonne K.

Cordialement, @+

VB:
=SI(ET(ENT(K3)=2;SUPPRESPACE(L3)="Nice");"OK";"DOUBLE FLUX")
 

Hasco

XLDnaute Barbatruc
Repose en paix
Bonjour,

Votre colonne k montre des chiffres mais qui sont sous forme de texte (et non directement calculable par excel).
Votre formule si vous les laissez en l'état doit comporter des " (guillemets) pour la comparaison :
SI(ET(K3="2";L3="Nice");"OK";"DOUBLE FLUX")
Si vous transformez vos chiffres textuels en nombre vous pourrez alors :
SI(ET(K3=2;L3="Nice");"OK";"DOUBLE FLUX")
Mais 'Nice' devra conserver ses guillemets

P.S. Pas bien compris les 'Ou autre' dans : " K si 2 ou autre et colonne L Nice ou autre"

Cordialement
 

Pièces jointes

  • SI ET.xlsx
    15.3 KB · Affichages: 3

Discussions similaires

Réponses
8
Affichages
502

Statistiques des forums

Discussions
312 836
Messages
2 092 656
Membres
105 481
dernier inscrit
JBBR974