Sélection de donnée automatique suite à choix dans menu déroulant

touristeamateur

XLDnaute Nouveau
Bonjour,

J'ai créé un menu déroulant avec les noms des salariés et, lorsque j'en ai sélectionné un, j'aimerais que s'affiche automatiquement le n° de Sécurité Sociale à côté.
Comment faire SVP, je sèche (mais faut dire que je ne suis pas très bon, je n'ose même pas dire "nul" en Excel :oops:)

Merci d'avance.
 

Pièces jointes

  • Suivi des congés.xlsx
    10.2 KB · Affichages: 23

touristeamateur

XLDnaute Nouveau
Bonjour,

Désolé pour le retard et tout d'abord merci pour ta réponse.
Chez moi, ça ne fonctionne pas pour la deuxième ligne si j'étire la formule. Ce serait quoi qui clocherait ?
Merci d'avance et bonne journée.
 

Pièces jointes

  • Suivi des congés test1.xlsx
    10.7 KB · Affichages: 25

touristeamateur

XLDnaute Nouveau
Bonsoir,

Merci de veiller si tard pour dépanner les naufragés d'Excel !
La formule ne fonctionne pas lorsque je la copie dans mon fichier, mais par contre elle fonctionne sur le tien. J'ai pas compris mais ce n'est pas grave : comme je n'ai que quelques noms et n° de SS, je les ai recopiés dans ton fichier!

Encore grand merci. Cordialement
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

Explications de la formule:
DECALER(réf, lignes, colonnes, [hauteur], [largeur])

Code:
=SI(A2="";"";DECALER('Liste déroulante'!$B$1;EQUIV(A2;NOM;0);0))
Cette formule sert à rechercher dans la colonne "B" de l'onglet "Liste déroulante" le N° de SS.
Pour ce faire nous cherchons la valeur exacte de A2 (Salarié 4) dans la plage dynamique "nom" ($A$2:$A$xxxxx) avec la fonction equiv().
cette fonction nous renverra un numero de l'emplacement de cette valeur.
Donc on décale de quatre lignes la cellule "$B$1" soit "$B$5 "N° de SS 4"

DECALER('Liste déroulante'!$B$1 ("N° de SS");EQUIV(A2;NOM;0);0) "4ème ligne de la plage nom";0 pour valeur exacte))

JHA
 

Discussions similaires

Membres actuellement en ligne

Statistiques des forums

Discussions
312 932
Messages
2 093 733
Membres
105 802
dernier inscrit
Witchun