Résultat erroné... Mais pourquoi ?

FaridP

XLDnaute Occasionnel
Bonjour à Toutes et à Tous,

Un bon exemple vaut mieux qu'un long discours, je vous joins donc un fichier dans lequel je décris mon souci.

En fait, si je ne remplis pas une cellule de mon tableau, le résultat renvoyé est le double de la réalité et je ne parviens pas à trouver la cause de cette erreur.

Merci de votre Aide toujours aussi précieuse.
A bientôt
Farid
 

FaridP

XLDnaute Occasionnel
Il ne fait que 9Ko et est zippé donc je capte pas.
Nouvelle tentative... [file name=Farid.zip size=8682]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/Farid.zip[/file]
 

Pièces jointes

  • Farid.zip
    8.5 KB · Affichages: 31
  • Farid.zip
    8.5 KB · Affichages: 24
  • Farid.zip
    8.5 KB · Affichages: 28

Monique

Nous a quitté
Repose en paix
Bonjour,

Ta formule comptait 2 fois la date de début si C2 était vide :
une fois en tant que cellule vide,
et 1 fois en tant que date <= plage des dates
Fais des essais avec cette formule :
=SI(NBVAL(B2:E2)>0;SOMMEPROD((($B2='')+($B2=Campagne))*(($C2='')+($C2<=DateBA)*($C2>0))*(($D2='')+($D2>=DateBA))*(($E2='')+($E2=CodeSérie));Fiches);0)

(($C2='')+($C2<=DateBA)*($C2>0))
équivaut à ça :
OU (C2 = '' ; ET( C2 contient une valeur; C2 <= DateBA))
 

FaridP

XLDnaute Occasionnel
Bonjour Monique,

Je ne me lasserai jamais de te remercier.
Je me suis cassé la tête (et les yeux) à essyaer de comprendre et il a suffit que tu passes par là pour qu'enfin je retrouve le sourire.

Mille fois merci à Toi.
A bientôt
Farid
 

Abel

XLDnaute Accro
Re Farid, bonjour Monique,

Je viens prendre un cours :

=SI(NBVAL(B2:E2)>0;SOMMEPROD((($B2='')+(Campagne=$B2))*(($C2='')+((DateBA>=$C2)*($C2>0)))*(($D2='')+(DateBAFin>=$D2)*($D2>0))*(($E2='')+(CodeSérie=$E2));Fiches);0)

J'ai rajouté un champs nommé pour la date de fin. Ce n'était pas nécessaire ?

J'en étais arrivé là lorsque Zor ... heu, Monique est arrivée. Hi hi.


Abel.

Message édité par: Abel, à: 14/09/2005 17:34
 

Discussions similaires

Statistiques des forums

Discussions
312 814
Messages
2 092 337
Membres
105 370
dernier inscrit
Leheryboriziny