Microsoft 365 (RESOLU) Formule avec SI, ET et OU imbriqués

guenfood

XLDnaute Occasionnel
Bonjour à tous,

Je m'arrache le peu de cheveux qu'il me reste pour écrire une formule avec des conditions imbriquées.
Mon tableau a 3 colonnes
Colonne A = Date de livraison
Colonne B = Statut
Colonne C où doit être la formule : SI Date colonne A est inférieur à aujourd'hui ET Colonne B = vide OU SI Aujourd'hui est inférieur ou = à 7 ouvrés à Date Colonne A ET Colonne B = vide, ALORS afficher "RETARD" sinon "OK"

L'imbrication SI, ET et OU me rend dingue 🤪
Merci par avance pour votre aide
 

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Guenfood,
Tentez ceci :
VB:
=SI(OU(ET(A1<=AUJOURDHUI();B1="");ET(AUJOURDHUI()-A1<=7;B1=""));"Retard";"ok")
J'ai mis 7 jours et non 7 jours ouvrés car je n'ai pas cette fonction sur mon XL.

Petite question :
Je met "Retard" si B vide ET :
Date colonne A est inférieur à aujourd'hui
OU
Aujourd'hui est inférieur ou = à 7 ouvrés à Date Colonne A

Pour moi dans les deux cas si date en A est < aujourd'hui alors Retard, qu'il y ait 1 ou 8 jours entre les deux dates. Pouvez vous confirmer ? Si oui, alors la seconde condition est inutile.
 

guenfood

XLDnaute Occasionnel
Bonjour Guenfood,
Tentez ceci :
VB:
=SI(OU(ET(A1<=AUJOURDHUI();B1="");ET(AUJOURDHUI()-A1<=7;B1=""));"Retard";"ok")
J'ai mis 7 jours et non 7 jours ouvrés car je n'ai pas cette fonction sur mon XL.

Petite question :
Je met "Retard" si B vide ET :
Date colonne A est inférieur à aujourd'hui
OU
Aujourd'hui est inférieur ou = à 7 ouvrés à Date Colonne A

Pour moi dans les deux cas si date en A est < aujourd'hui alors Retard, qu'il y ait 1 ou 8 jours entre les deux dates. Pouvez vous confirmer ? Si oui, alors la seconde condition est inutile.
Merci beaucoup. C'est tout bon comme ça. J'ai juste arrondi à 10 au lieu de 7 pour prendre en compte les week-end. Mais cela fonctionne bien
 

guenfood

XLDnaute Occasionnel
Ca j'avais compris, mais
si la date est hier alors Retard
si la date est il y a un mois alors Retard.
Alors vu de ma fenêtre :
VB:
=SI(ET(A2<AUJOURDHUI();B2="");"RETARD";"OK")
est suffisant, non ?
Ah non. J'ai dû mal m'exprimer dans mon besoin.
Parce que si la date est dans 6 jours, je dois être en retard aussi. Car je n'ai pas un écart de 7 jours inclus entre aujourd'hui et la date future de ma colonne A
 

Statistiques des forums

Discussions
312 817
Messages
2 092 366
Membres
105 379
dernier inscrit
alboub