requete sur les heures

nicedep

XLDnaute Nouveau
Bonjour, et merci d'être toujours aussi aimables et courtois.
J'ai une question bête, j'ai cherché dans le faq et pas trouvé désolé ..
Je ne parciens pas à faire une requête pour trouver le nombre de fois ou l'heure est superieure à 12:00:00 et inférieure à 14:00:00, par exemple.
Merci de votre aide.
Tof
 

Tibo

XLDnaute Barbatruc
Re : requete sur les heures

Bonjour,

Sous toute réserve (faute de fichier exemple) :

Code:
=SOMMEPROD((plage_cellules>="12:00"*1)*(plage_cellules<="14:00"*1))

Si pas ça, reviens avec plus de précisions et notamment un petit bout de fichier exemple

@+
 

nicedep

XLDnaute Nouveau
Re : requete sur les heures

Bonjour,

Sous toute réserve (faute de fichier exemple) :

Code:
=SOMMEPROD((plage_cellules>="12:00"*1)*(plage_cellules<="14:00"*1))

Si pas ça, reviens avec plus de précisions et notamment un petit bout de fichier exemple

@+

Voilà j'ai mis un petit bout de fichier, sommeprod a priori ca le fait pas, merci beaucoup
 

Pièces jointes

  • exemplenicedep.xls
    17 KB · Affichages: 52

Tibo

XLDnaute Barbatruc
Re : requete sur les heures

re,

sur la base de ton fichier, la formule que je t'ai proposé donne ceci :

Code:
=SOMMEPROD((B2:B27>"12:00"*1)*(B2:B27<"14:00"*1))

et donne 4 comme résultat, ce qui semble cohérent après vérification.

@+
 

nicedep

XLDnaute Nouveau
Re : requete sur les heures

Oui oui, bien sur ca marche, je suis un ane j'avais pas mis le *1, mais en fait je sais même pas à quoi il sert...???
Ce qui est sur c'est que si on le met met c'est pas juste ....
Merci beaucoup
 

DIGGERJACK

XLDnaute Occasionnel
Re : requete sur les heures

Bonsoir le forum, Tibo, nicedep

tu peux même sélectionner tes plages horaires de calcul à partir de liste déroulantes faisant suite à la formule de Tibo

Bonne soirée
 

Pièces jointes

  • exemplenicedep(1).xls
    26 KB · Affichages: 53

Discussions similaires

Statistiques des forums

Discussions
312 884
Messages
2 093 252
Membres
105 658
dernier inscrit
Mario Richard