XL 2016 Renvoie valeur selon plusieurs critères dans une cellule

maxdhavys

XLDnaute Nouveau
Bonjour à tous,

Je bloque actuellement sur le fait de renvoyer une valeur 1 ou 0 selon plusieurs critères textuels dans une cellule donnée.

Il y a bien les fonctions cherche() ou index() mais vraiment je bloque et pourtant cela ne semble pas si compliqué :s

Voici un petit fichier à titre d'exemple :)

Une âme charitable veut-elle bien me venir en aide ?

Max
 

Pièces jointes

  • Exemple.xlsx
    27.9 KB · Affichages: 30

maxdhavys

XLDnaute Nouveau
Merci beaucoup CISCO,

Le petit exemple que j'ai mis n'est pas tout à fait bon, le problème réside dans le fait que les paramètres ne se suivent pas forcément.

Voici l'exemple corrigé en PJ
 

Pièces jointes

  • Exemple.xlsx
    33.2 KB · Affichages: 32

CISCO

XLDnaute Barbatruc
Bonsoir

Et pourquoi n'obtient-t'on pas un 1 en B7 ? Si cela dépend aussi de l'année, cela n'est pas très difficile d'en tenir compte. S'il y a d'autres conditions, cela serait bien de nous donner assez d'exemples pour que nous comprenions bien ton besoin.

@ plus
 

maxdhavys

XLDnaute Nouveau
Nous n'obtenons pas 1 en B7 car l'année est 1987 et non 1988.

Voici en PJ la réponse à mon pb, j'utilisait la multiplication au lieu de l'addition :
=SI(NON(ESTERR((TROUVE("noir 3 ans";A1)+TROUVE("1988";A1))));1;0)
 

Pièces jointes

  • Exemple.xlsx
    33.6 KB · Affichages: 25

maxdhavys

XLDnaute Nouveau
Pardon mais il y a un paramètre dont je n'ai pas tenu compte.

Comment peut-on faire pour tenir compte du fait qu'il ne faut que cela soit effectif pour les chien et le chat mais pas pour le cheval (cf.nouveau fichier)

Bien à vous,
Maxime
 

Pièces jointes

  • Exemple.xlsx
    37.2 KB · Affichages: 30

Discussions similaires

Statistiques des forums

Discussions
312 816
Messages
2 092 329
Membres
105 367
dernier inscrit
jych