Microsoft 365 Recherche si valeurs multiples dans une cellule

cdric78

XLDnaute Junior
Bonjour à tous,

Je n'arrive pas trouver la formule pour répondre à mon besoin. Même si je pense que cela est simple je bloque sur cette formule.
Je souhaite vérifier la présence éventuelle de plusieurs valeurs dans une cellule et renvoyer la valeur trouvée.

Si C2 contient "C5P" ou "C5G" ou "C7Q" alors il faut ajouter la valeur trouvée en B2.

Merci beaucoup pour votre aide.
 

Pièces jointes

  • Classeur4.xlsx
    9.9 KB · Affichages: 4

JHA

XLDnaute Barbatruc
Bonjour à tous,

Tu peux essayer cette formule
VB:
=SI(ESTNUM(CHERCHE("C5P";C2));"C5P";SI(ESTNUM(CHERCHE("C5G";C2));"C5G";SI(ESTNUM(CHERCHE("C7Q";C2));"C7Q";"Pas trouvé")))

JHA
 

Pièces jointes

  • Classeur4.xlsx
    10.3 KB · Affichages: 1

Discussions similaires

Réponses
9
Affichages
256

Statistiques des forums

Discussions
312 886
Messages
2 093 273
Membres
105 666
dernier inscrit
MAGOUROMY