XL 2010 recherche valeur sur deux variables

IMRANE

XLDnaute Occasionnel
Bonjour le forum
je cherche une valeur lie a deux variable sur un tableau
Pour bien expliquer mon cas j ai mis une pièce joint pour éclaircir ma question
et merci
 

Pièces jointes

  • 1RECHRECHE VALEUR.xlsm
    10.5 KB · Affichages: 3

sylvanu

XLDnaute Barbatruc
Supporter XLD
Re,Pas sur d'avoir tout compris.
Peut être en modifiant Worksheet_Change :
VB:
Private Sub Worksheet_Change(ByVal Target As Excel.Range)
    If Not Intersect(Target, [C7:C35]) Is Nothing Then
        If Target <> "" Then
            [O15] = Target: Calculate
            If [P15] = 0 Then MsgBox "ATTENTION."
        End If
    End If
... suite du code
Quand on choisit une référence, on recopie cette réf dans O15 et on regarde si P15 est nul ou non.

NB: J'ai modifié la formule en P15 pour éviter les #N/A quand une réf n'est pas trouvée, avec :
Code:
=SIERREUR(INDEX('TAB LIV'!D5:D150;EQUIV(LIVRAISON!$O$15;'TAB LIV'!C5:C150;0);EQUIV(LIVRAISON!O14;Tableau23[[#En-têtes];[ABDELMALEK FES]:[Colonne12]];0));0)
 

Pièces jointes

  • 01NAPPLI.xlsm
    901.7 KB · Affichages: 3

IMRANE

XLDnaute Occasionnel
re
dans mon fichier vous cliquez sur l icone NOUVEAUX situé a la droite du bon livraison ca va effacer tous
après vous choisissez donc le nom ABDELMALEK FES et en suite vous sélectionnez la première référence dans la cellule "C7" BTR 1001
A ce moment la valeur de la cellule "P15" sera le nombre 7
la première référence "C7" qui est le facteur du changement de valeur de "P15" soit 0 ou >0
c est tout ce que je veux en changeant le nom et la première référence si j ai la valeur 0 dans "P15"
il ne se passe rien si j ai un nombre supérieure a 0 je vais avoir un message "ATTENTION"
Espérant que je i bien expliquer
merci pour votre patience
 

Statistiques des forums

Discussions
313 229
Messages
2 096 394
Membres
106 601
dernier inscrit
Virgin766