XL 2010 Recherche valeur dans un tableau

grisouille

XLDnaute Nouveau
Bonjour à tous,

Je voudrais récupérer automatiquement au fur et à mesure que je renseigne mon tableau , sur un onglet différent certaines valeurs du tableau soit avec des formules , soit par macro en fonction d'un critère.

Merci d'avance pour votre aide.
 

Pièces jointes

  • Classeur1.xlsx
    12.7 KB · Affichages: 50

Modeste geedee

XLDnaute Barbatruc
Bonsour®
Bonjour à tous,

Je voudrais récupérer automatiquement au fur et à mesure que je renseigne mon tableau , sur un onglet différent certaines valeurs du tableau soit avec des formules , soit par macro en fonction d'un critère.

Merci d'avance pour votre aide.

préalable !
le tableau feuille 1 doit être trié selon la colonne C (CC)

feuille 2
en B2 :
=SI((COLONNE()-1)<=NB.SI(Feuil1!$C:$C;$A2);INDEX(Feuil1!$D:$D;COLONNE()-2+EQUIV($A2;Feuil1!$C:$C;0));"")
en B3 :
=SI((COLONNE()-1)<=NB.SI(Feuil1!$C:$C;$A2);INDEX(Feuil1!$A:$A;COLONNE()-2+EQUIV($A2;Feuil1!$C:$C;0));"")

sélectionner ces 2 cellules
et recopier vers le bas et à droite selon besoin
upload_2017-2-1_18-7-47.png
 

Discussions similaires

Statistiques des forums

Discussions
312 890
Messages
2 093 350
Membres
105 696
dernier inscrit
FrancisR