Rapport diificile à faire(sans etre lent)

  • Initiateur de la discussion XGuarden
  • Date de début
X

XGuarden

Guest
Bonjour, j'ai une base de donnée qui contient 3 colonne.
A: Année
B: Semaine
C: Longeur de chemin

Il peut y avoir plusieur donnée identique....(plusieur donnée par semaine)

Je cherche un moyen de faire un rapport qui permet en indiquant deux année et un numéro de semaine de faire la comparaison entre les deux année.
Exemple
Si je dit la semaine 10, il fera la compilation des donnée inférieur à la semaine 10 pour les deux année et me donera la comparaison entre les deux.

Merci d'Avanc, et n'ésiter pas à me posser des questions si ma description est incompréensible(ce qui risque d'être le cas)
 
X

XGuarden

Guest
Encore une tentative : [Le fichier devrai etre ici] [file name=Chemin_20050809135703.zip size=39079]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/Chemin_20050809135703.zip[/file]
 

Pièces jointes

  • Chemin_20050809135703.zip
    38.2 KB · Affichages: 9

Monique

Nous a quitté
Repose en paix
Bonjour,

Tes plages sont nommées par formule : tu peux ajouter ou supprimer des lignes ou des données sans rien modifier.
La comparaison entre 2 années : SommeProd

[file name=CheminXguarden.zip size=41807]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/CheminXguarden.zip[/file]
 

Pièces jointes

  • CheminXguarden.zip
    40.8 KB · Affichages: 21
X

XGuarden

Guest
Le problème n'est pas la, tu aurai d ut'en douter en voyant les formules. Le problème est que je dois faire cela mais en indiquant une semaine(facile). Et le problème, c'Est de calculer également les semaines avant de la meme année
 

Monique

Nous a quitté
Repose en paix
Re,

Si je n'ai pas compris quelque chose à ta demande, explique toi, alors.
Quand tu dis que le problème n'est pas là, je ne sais pas où est 'là'.

En regardant tes formules, j'ai vu du Somme.Si
Mais si tu as des conditions 'date<= choix' et 'date>= semaine 01 du choix',
le Somme.Si ne va pas
C'est donc SommeProd, qui accepte jusqu'à 30 arguments

Si tu tapes en J17
=SOMMEPROD((Semaine<=(J$15*100+$I$14))*(Semaine>=(J$15*100+1)))
ça te donne le nb de semaines qui sont :
<=(année choisie *100 + semaine choisie)
et
>=(année choisie * 100+1) soit la semaine n° 1 de l'année choisie

Tu complètes la formule avec la longueur :
SOMMEPROD((Semaine<=(J$15*100+$I$14))*(Semaine>=(J$15*100+1))*Longueur)
te renvoie la somme des cellules correspondantes de la colonne 'Longueur'

Pour ce genre de fonctions, * équivaut au ET des formules conditionnelles (+ équivaut au OU et - veut dire 'Sauf')
SommeProd((PlageA=Condition1)*(PlageB=Condition2)*plage à sommer)

Fais un essai en G17 :
=SOMMEPROD((Saison=G$15)*Longueur)/1000
te renvoie la même chose que
=SOMME.SI(Saison;G$15;Longueur)/1000
 

Discussions similaires

Membres actuellement en ligne

Aucun membre en ligne actuellement.

Statistiques des forums

Discussions
312 827
Messages
2 092 557
Membres
105 451
dernier inscrit
mariane_lp