Microsoft 365 Valeur rechercher selon plusieurs critères et sur plusieurs pages par rapport à une cellule

Varona Rodriguez

XLDnaute Nouveau
Bonjour à tous
tout d'abord je m'excuse si je ne suis pas au bon adroit du forum pour poser ma question

voici ce que je recherche
dans mon Xls trois feuille
1 = tableau général
2 = base de donnée (celle-ci sera régulièrement écrasé par une nouvelle base de données)
3 = le mots clé de recherche
le formule devra être sur la feuille 1 en C9 ou en C10,
elle qui sera en C9 devra vérifier si dans la feuille 2(base de données) se trouve dans la colonne "C"ce trouve au moins une fois 1'un des mots clé de la feuille 3 par rapport au nom ce trouvant sur la feuille 1 en A9

et j'aurai besoin de savoir ou changer :
la colonne de recherche
le mot clés à rechercher
et le nom pour qui on recherche

pour faire simple si :
si "trucbidul je m'en fou1" à un fois "Chauffeur permis C" dans la colonne "c" de la feuille2 marquer "oui" si non marquer "non"
et si en plus le cellule pour être d'un certaine couleur ce serait génial comme par exemple si "oui" vert "si "non "rouge"


et évidement j'ai déjà fais plein de recherche mais je bloque toujours
voici mes recherches :
RECHERCHEV(A391;Données!A:B;2;FAUX);
SI(NB.SI(Données!C:J;" ")>=1;"oui";"non")
if(ET(B391;D391);"oui";"non")
SI(SOMME(ESTNUM(CHERCHE(SI(liste!$A$2:$A$10<>"";liste!$A$2:$A$10);A3))*LIGNE(liste!$A$2:$A$10))>0;"Oui";"Hors Scope")
ent(alea()*AMU - Secouriste ambulancier
SI(etNB.SI(Données!C:C;"AMU - Secouriste ambulancier")>=1;"oui";"non")
merci pour votre aide
Belle journée
 

Pièces jointes

  • Classeur1.xlsx
    105.8 KB · Affichages: 17

Varona Rodriguez

XLDnaute Nouveau
Bonjour FHA
la je t'avoue que tes formule sont bien compliqué pour moi

j'ai bien compris que tu voulais revoir cette base de données

en reclassent le tout

mais si tu aurais un formule beaucoup plus simple pour m'afficher "oui" ou "non" il à l'une des compétences sur la feuil3

donc dans une cellule en "feuil1" afficher si "oui" ou "non" il a la ou moins une fois compétence en "feuil2" "...." qui se trouve en feuil3

pour essayé de faire claire sur la feuil1 (via menu déroulant) je vais sélectionner un nom dans une colonne qui aura comme tire une compétence et sur la même ligne que le nom je devrai avoir un "oui" ou un "non"

merci de ton aide
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

j'ai fait au plus simple, recopie des compétences en Feuil3.
Liste de choix Feuil1 avec Table_1
Recherche dans feuil3 colonnes E & F pour déterminer si oui ou non

JHA
 

Pièces jointes

  • Classeur1 (10).xlsx
    23.5 KB · Affichages: 4

Varona Rodriguez

XLDnaute Nouveau
Hello JHA
je reviens vers toi car je reste bloqué sur une formule toujours la même
pour reprendre j'ai deux cellules qui ont toutes les deux deux valeurs textes affiché via le menu déroulant "validation de données"
la valeur 1 dans la cellule A1
la valeur 2 dans la cellule A2
celle-ci doivent être au moins une fois dans une feuil nomé "base de donné"
A1 doit être ou moins une fois dans la colonne A dans "base de données"
et
A2 doit être ou moins une fois dans les colonnes BCDE dans "base de données"
si oui pour les deux recherche "oui si non "" (vide)

je tente depuis quelques heures mais sans succes
voici mes recherches :

=SI(et(A1;'Base de données'!A:A&A2;'Base de données'!C:j)"oui","")
=INDEX('Base de données'!A2:A9000;EQUIV(A1;A2;"oui");"")
=ET(NB.SI(('Base de données'!A:A;A1)=1)*(('Base de données'!C:J;A2)=1);"oui";"")

aurais tu une idée pour m'aider
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

Aucune des formules décrites ne peuvent fonctionner dans l'état.

=SI(et(A1;'Base de données'!A:A&A2;'Base de données'!C:j)"oui","")
=INDEX('Base de données'!A2:A9000;EQUIV(A1;A2;"oui");"")
=ET(NB.SI(('Base de données'!A:A;A1)=1)*(('Base de données'!C:J;A2)=1);"oui";"")


Peux-tu annexer un bout de fichier pour clarifier ta demande et pour nous aider à travailler sur ton soucis.

JHA
 

Varona Rodriguez

XLDnaute Nouveau
Oui sans soucis
tu remarqueras que c'est le même type de fichier car les précédentes solutions ne convenaient pas
car je suis bloqué sur cette mise en page et sur le nombre d'onglet
non pas que je n'ai pas acces mais que le souhaite doit être par une formule et dans la cellule
ce fichier est partagé entre plusieurs personnes
par la suite j'ai un autre formule qui renvoie la réponse sur une autre feuille de cette manière je protège mes formules contre toutes sources d'écritures
 

Pièces jointes

  • Tableau général des compétences.xlsx
    497.3 KB · Affichages: 5

Discussions similaires

Statistiques des forums

Discussions
313 287
Messages
2 096 833
Membres
106 758
dernier inscrit
JM9