Microsoft 365 Problème pour afficher les rangées vides

moanin

XLDnaute Impliqué
Bonsoir à tous ;)



Je cherche à afficher les lignes vides.

J'ai 146 colonnes.

Je crée une colonne vide.

Je tape :

=SI(NB.SI(A2:DP2;"")=146;"Ligne vide";"")

(Curieusement quand je saisis > 2 points suivi de DP2 cela insére > :) sur le post > donc après (A2 : lire > 2 points suivi de DP2 à la place du :D)

A2 et DP2 > 1° et dernière colonne.

Résultat : toutes les cellules de la colonne de ma formule sont vierges alors qu'il y a une rangée vide…

Quelqu'un peut-il m'expliquer où est l'erreur ?

Merci
 
Dernière édition:

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Moanin,
Quelque chose m'échappe :
A2 à DP2 ça fait 120 colonnes:
VB:
=NB.SI(A2:DP2;"") = 120
pour 146 il faudrait aller jusqu'à la colonne EP :
Code:
=NB.SI($A$2:$EP$2;"")=146
et dans ce cas :
Code:
=SI(NB.SI($A$2:$EP$2;"")=146;"Ligne vide";"")
donne bien comme réponse "Ligne vide"
 

moanin

XLDnaute Impliqué
Bonsoir Sylvanu ;)

Oui, j'ai fait une erreur en effet…

En fait, je trouve 119.

(En faisant glisser la ligne des titres de gauche à droite en bas : dans le petit menu déroulant "somme" / "nombre" s'affiche le nombre 119)

Mais, bon, le problème n'est pas là, la ligne vide est la 500.

Or, si je fais :

=SI(NB.SI(A500:DP500;"")=119;"Ligne vide";"")
[Pareil : quand je saisis > 2 points suivi de DP2 cela insére > :Dsur le post > donc après (A2 : lire > 2 points suivi de DP2 à la place du :D)]

La ligne vide 500 n' affiche pas "ligne vide" dans la cellule de la formule, elle est vide comme toutes les autres qui contiennent des données :(
Impossible de savoir qu'elle est vide !
 
Dernière édition:

TooFatBoy

XLDnaute Barbatruc
Bonjour,

Curieusement quand je saisis > 2 points suivi de DP2 cela insére > :) sur le post > donc après (A2 : lire > 2 points suivi de DP2 à la place du :D
Ca n'a rien de curieux : ": D" est une émoticone.
Si tu utilisais la balises code il n'y aurait pas ce problème d'affichage. ;)
Code:
=SI(NB.SI(A2:DP2;"")=146;"Ligne vide";"")


Code:
=SI(NB.SI(A500:DP500;"")=119;"Ligne vide";"")
La ligne vide 500 n' affiche pas "ligne vide" dans la cellule de la formule, elle est vide comme toutes les autres qui contiennent des données :(
Impossible de savoir qu'elle est vide !
A500 : DP500 ça fait 120 colonnes et non 119, donc si tu as 120 cellules vides, la formule renvoie 120 et non 119, donc tu ne peux pas avoir le message "Ligne vide".
 
Dernière édition:

TooFatBoy

XLDnaute Barbatruc
Ou plus simple. Au lieu de compter les cellules vides, comptez les cellules non vides.
Si une cellule est non vide, la ligne est non vide :
VB:
=SI(NB.SI(A2:DP2;"<>");"";"Ligne vide")
😂
Le résultat ne sera pas forcément le même... :(

Par exemple s'il y a sur la ligne, une formule qui retourne "", #7 retournera tout de même "Ligne vide", alors que #8 ne retournera pas "Ligne vide". ;)
 

sylvanu

XLDnaute Barbatruc
Supporter XLD
Pas au sens XL du terme. Si vous faites :
VB:
=ESTVIDE(A1)
Cela retourne FAUX pour des caractères, ou une formule qui renvoie "".
Cela ne retourne VRAI que si la cellule est réellement vide. ;)
C'est la différance entre une cellule vide et une cellule dont le résultat est vide.
 

job75

XLDnaute Barbatruc
Bonjour moanin, le forum,

D'après ce que je comprends du post #3 NB.SI(A2: DP2;"") renvoie 119 au lieu de 120.

Cela prouve qu'il y a une valeur différente du texte vide "" dans une cellule de la plage.

Peut-être un espace ???

Pour ne pas compter les espaces utiliser "><" :
Code:
=REPT("Ligne vide";NON(NB.SI(A2:DP2;"><")))
A+
 

Discussions similaires

Réponses
15
Affichages
941

Statistiques des forums

Discussions
312 913
Messages
2 093 534
Membres
105 750
dernier inscrit
fred13340