XL 2013 Numérotation automatiques

esftel

XLDnaute Occasionnel
Bonjour le Forum,

Me voila de retour sur mon problème qui finalement plus complexe que je l'imaginais.

En effet je souhaiterais créer une numérotation en fonction de la colonne "num semaine", "Groupe" et "Secteur".
Méthode avec formule, sans VBA

Je ne vous cache pas que je cale :(

Voici un petit exemple qui, je l'espère vous aidera à mieux comprendre ma demande, et un fichier joint
Num Auto (avec formule)NUM SEMAINEGROUPESecteur
1​
47Groupe 1B
1​
47Groupe 2A
1​
47Groupe 2A
2​
47Groupe 2B
2​
47Groupe 3A
1​
48Groupe 2A
1​
48Groupe 2A
1
48Groupe 3B
2​
48​
Groupe 3A

Merci d'avance,

Franck T
 

Pièces jointes

  • Exemple EXLDOW.xlsx
    12.6 KB · Affichages: 10
Dernière édition:

esftel

XLDnaute Occasionnel
Bonjour et merci pour ta présence sur ce poste.

Je souhaiterais donner un ordre en fonction du num semaine du secteur et aussi le groupe.

En reprenant le tableau lors qu'une une ligne est identique le même numéro d'ordre est attribué

Le numéro de semaine est la base de cette numérotation ! puis vient le secteur puis le groupe (désolé les colonnes ne sont pas dans l'ordre)

j'ai refait un exemple (j'ai aussi corrigé une erreur l'exemple de mon premier post)

Num Auto (avec formule)NUM SEMAINEGROUPESecteur
147Groupe 1B
147Groupe 2A
147Groupe 2A
247Groupe 2B
247Groupe 3A
148Groupe 2A
148Groupe 2A
248Groupe 3A
148Groupe 3B
148Groupe 3B

En espérant avoir été plus clair ....

Merci de ton aide....
 

patricktoulon

XLDnaute Barbatruc
bonjour exemple
demo.gif


la formule à adapter a ton contexte
VB:
=SI(B1-MIN(B:B)=0;1;B1-MIN(B:B)+1)
 

esftel

XLDnaute Occasionnel
Bonjour PatrickToulon,

j'avais déjà une formule comme celle-ci mais l'exemple que tu me donne tient seulement compte de la colonne n°semaine,.

c'est justement là que je bloque, je n'arrive pas à créer une numérotation en tenant compte des colonnes suivantes (voir mon exemple.)

En tous cas merci pour ton aide....
 

patricktoulon

XLDnaute Barbatruc
re
en formule difficile de trouver une cohérence ou un sens avec tes 3 colonnes afin d'automatiser la numérotation
tu a
1 47 groupe1 B
2 47 groupe2 B
et ensuite tu a
1 48 groupe2 A
ma fois si tu y trouve une cohérence ou un sens tu est le seul
a mon avis là il te faut faire un TCD ou alors par macro vba mais c'est coton et je suppose que c'est qu'une partie du tableau
 

esftel

XLDnaute Occasionnel
Bonjour à tous,

Un essai au hasard mais pas les mêmes résultats.

JHA
Bonjour messieurs,

Merci pour votre aide, mais je me rends compte que ca va être compliqué, peut être que je vais devoir revoir l'organisation de mon fichier.

JHA, pas mal ta formule elle répond presque, il manque pas grand chose pour obtenir le résultat souhaité.

un grand merci pour votre aide....
 
Dernière édition:

Discussions similaires

Réponses
5
Affichages
201

Statistiques des forums

Discussions
312 799
Messages
2 092 239
Membres
105 299
dernier inscrit
doudounapnap