nombre de cellules dont la valeur est comprise entre deux dates

farfadette13

XLDnaute Nouveau
bonjour,
voila j'ai un tableau avec 2 colonnes de dates et je voudrais compter le nombre de cellules dont la valeur est comprise entre deux dates

par exemple dans ce cas :

date reception date traitement
01/07/2007 01/07/2007
05/07/2007 08/07/2007
01/07/2007 05/07/2007
23/07/2007 25/07/2007
31/07/2007 03/08/2007
03/08/2007 04/08/2007
13/06/2007 15/06/2007
29/06/2007 30/06/2007

y'a-t-il une formule permettant de savoir combien de cellules sont comprise entre le1/07/2007 et le 31/07/2007???

et pour combien de ces cellules la date de traitement est inférieure ou égale à la date de réception + 3 jours???

merci d'avance
 

wazzebu

XLDnaute Occasionnel
Re : nombre de cellules dont la valeur est comprise entre deux dates

Bonjour,

Ce que je ferais c'est une mise en forme conditionnelle:

par exemple en vert les cellules
cellules sont comprise entre le1/07/2007 et le 31/07/2007

et en rouge
cellules la date de traitement est inférieure ou égale à la date de réception + 3 jours

ensuite par formule (je crois) on peut compter les cellules de la même couleur.

Donc regarde du côté des MFC (mises en formes conditionelles) et des formules pour compter les cellules de couleur.

@+
 

Tibo

XLDnaute Barbatruc
Re : nombre de cellules dont la valeur est comprise entre deux dates

Bonjour farfadette, wazzebu,

à essayer avec SOMMEPROD :

Nombre de dates entre le 1er juillet et le 31 juillet :

=SOMMEPROD((A1:B8>="01/07/2007"*1)*(A1:B8<="31/07/2007"*1))


Nombre de lignes pour lesquelles le traitement est inférieur ou égal à 3 jours :

=SOMMEPROD((B1:B8-A1:A8<=3)*1)

teste et dis nous

@+
 

chris

XLDnaute Barbatruc
Re : nombre de cellules dont la valeur est comprise entre deux dates

Bonjour

Pour des dates sur la plage C2 :10
Si tu dois compter sur une seule colonne
=NB.SI(C2:C10;">=01/07/07")-NB.SI(C2:C10;">31/07/07")
sur les deux à la fois
=NB.SI(C2 : D10;">=01/07/07")-NB.SI(C2 : D10;">31/07/07")
Pour les écarts <= 3
=SOMMEPROD((D2 : D10-C2:C10<=3)*1)

Edit : enlever les espaces dans les dormules.
Bonjour Tibo qui a été plus rapide
 
Dernière édition:

alexandre766

XLDnaute Nouveau
Re : nombre de cellules dont la valeur est comprise entre deux dates

bonjour,

en effet ça marche si on remplit à la main la date. ex:02/01/2008

mais comment faire si on veut qu'il prenne la valeur dans une cellule. Il n'aime pas du tout [...]<C24[...] par exemple car il va rechercher "bêtement" C24 dans la colonne définie.

Existe-t-il une solution??

merci

A+
Alexandre
 

Discussions similaires

Réponses
11
Affichages
637
Réponses
2
Affichages
593

Statistiques des forums

Discussions
313 276
Messages
2 096 760
Membres
106 743
dernier inscrit
sshkm16