maintenance

biomed

XLDnaute Junior
rebonjour a tous
je relace le fil :Lien supprimé
est-ce que quelqu'un pourrait m'aider car j'ai beau chercher, je ne trouve pas
est-ce qu'une macro pourrait resoudre ce probleme,
merci
 

Charly2

Nous a quittés en 2006
Repose en paix
Bonjour biomed, le forum,

Voici une tentative de réponse sans macro. Le seul problème rencontré est à 7500 (quel 'kit' ?).

Dis-moi ce que tu en penses et si j'ai bien compris ce que tu souhaites faire...

Amicalement
Charly [file name=BiomedV1.zip size=20008]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/BiomedV1.zip[/file]
 

Pièces jointes

  • BiomedV1.zip
    19.5 KB · Affichages: 240

Charly2

Nous a quittés en 2006
Repose en paix
Re à tous,

Biomed, j'ai oublié qu'il y avait une valeur à l'origine lors du calcul de la date de maintenance prévue, il faut que tu modifies la formule :

=(D6-C6)/((C6-'Géné A'!$B$4)/NB.SI('Géné A'!$B$4:$M$34;'>0'))+MAINTENANT()

Voili voilà ! à toi de jouer !

Amicalement
Charly
 
B

biomed

Guest
bonjour et merci pour ton aide
a 7500 h, on fait un kit 2500, a 10000h, on fait un kit 10000, a 12500h, on fait un kit 2500, a 15000h, un kit 5000 et ainsi de suite
tu vois pourquoi je bloque et me demande si par macro ce ne serait pas plus simple car par formule on est limite
encore une fois merci :)
 

Charly2

Nous a quittés en 2006
Repose en paix
bonjour biomed, le forum,

Je ne suis pas persuadé qu'il y ait besoin d'une macro pour faire ce que tu demandes.

Dans ta feuille Maintenances, en D6 tu entres la formule :

=SI(10000-MOD(C6;10000)<=200;10000;SI(7500-MOD(C6;7500)<=200;2500;SI(5000-MOD(C6;5000)<=200;5000;SI(2500-MOD(C6;2500)<=200;2500;''))))

et pour la date présionnelle de maintenance, tu as la formule que je t'ai indiquée dans mon précédent post que tu modifies ainsi :

=SI(7500-MOD(C6;7500)<=200;7500-C6;D6-C6)/((C6-'Géné A'!$B$4)/NB.SI('Géné A'!$B$4:$M$34;'>0'))+MAINTENANT()

Tiens nous au courant ;)

Amicalement
Charly
 

Statistiques des forums

Discussions
312 938
Messages
2 093 776
Membres
105 821
dernier inscrit
OZOS6868