XL 2013 Macro filtre automatique à partir de l'adresse d'une cellule sur une autre feuille

Jaqk

XLDnaute Nouveau
Bonjour,

Je me permets de solliciter l'aide de personnes aguerrie en VBA.

Je souhaiterais pouvoir sélectionner n'importe quelle cellule du tableau en bleu de la feuille "LM2022" . lancer la macro et obtenir automatiquement les données filtrée dans la feuille 2.

Plus concrètement:
Si par exemple je sélectionne la cellule E7 dans la feuille "LM2022", je souhaite obtenir le détail des 12,50 avec un filtre automatique sur la feuille 2.

Je sais qu'un simple TCD résoudrait l'affaire mais je ne peux pas le faire pour d'autres raisons.

J'espère avoir été clair, c'est mon premier post...

Merci d'avance à ceux qui pourront m'aider!
 

Pièces jointes

  • TEST.xlsx
    12.8 KB · Affichages: 4

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Jaqk, et bienvenu sur XLD,
Pourquoi passer par du VBA ?
Si j'ai bien compris la problématique, cela peut se résoudre avec :
VB:
=SOMME.SI.ENS(Feuil2!$D$5:$D$1000;Feuil2!$B$5:$B$1000;$C7;Feuil2!$A$5:$A$1000;COLONNE()-3)
COLONNE()-3 donne 1 pour la colonne D car Colonne D=4, et 1 pour janvier.
 

Pièces jointes

  • TEST (9).xlsx
    12.8 KB · Affichages: 2

vgendron

XLDnaute Barbatruc
Hello
je n'ai pas compris la meme chose que toi @sylvanu

VB:
Sub Filtrer()
If ActiveCell = "" Then
    MsgBox "veuillez selectionner une cellule non vide"
    Exit Sub
End If
Nature = Range("C" & ActiveCell.Row)
mois = Cells(5, ActiveCell.Column)

nummois = Format(DateValue("01 " & mois & " 2000"), "m")
With Sheets("Feuil2")
    .AutoFilterMode = False
    Set zone = .Range("A4").CurrentRegion
    
    zone.AutoFilter Field:=1, Criteria1:=nummois
    zone.AutoFilter Field:=2, Criteria1:=Nature
    .Activate
End With
    
End Sub
 

sylvanu

XLDnaute Barbatruc
Supporter XLD
Re,
Effectivement, après relecture :
Je souhaiterais pouvoir sélectionner n'importe quelle cellule du tableau en bleu de la feuille "LM2022" . lancer la macro et obtenir automatiquement les données filtrée dans la feuille 2.
Je pense que vous avez raison. :)

Par contre je n'en vois pas l'intérêt, car si le tableau bleu recèle toutes les infos de la feuil2, quel intérêt d'aller refiltrer la feuil2 ?

C'est comme à l'école :
Si tu ne lis pas les consignes, t'as 0 !
 

Jaqk

XLDnaute Nouveau
Bonjour,

Tout d'abord merci beaucoup pour vos réponses!! Je ne m'attendais pas à avoir une réponse si rapide.

@vgendron: c'est parfait c'est exactement ce que je cherchais!

@sylvanu: Mon but en filtrant la feuille 2 est de pouvoir voir le détail de ce qui est renseigné dans le tableau bleu.

Bonne journée à vous
 

Discussions similaires

Statistiques des forums

Discussions
302 038
Messages
1 999 893
Membres
214 702
dernier inscrit
Gaël0410