XL 2019 Liste déroulante non restreinte et msgbox

BEGEX

XLDnaute Nouveau
Bonjour à tous,
Voici mon problème :
Feuil1 j'ai un tableau. En colonne B les données sont validées par une liste contenue en feuil2.
Cette validation de données n'est pas restreinte, l'utilisateur peut donc entrer le texte qu'il souhaite.
Néanmoins j'aimerais une alerte par msgbox au cas ou l'entrée soit non conforme.
par exemple : "Attention ce nom n'est pas conforme à la liste de référence".
Voilà pouvez-vous m'aider ?
Un grand Merci
 

job75

XLDnaute Barbatruc
Bonjour BEGEX, bienvenue sur XLD, Dudu2,

Oui, voyez le fichier joint et cette macro :
VB:
Private Sub Worksheet_Change(ByVal Target As Range)
On Error Resume Next
If IsEmpty(Target) Or Application.CountIf(Evaluate(Target.Validation.Formula1), Target) Then Else MsgBox "Attention ce nom n'est pas dans la liste de référence...", vbInformation
End Sub
A+
 

Pièces jointes

  • Classeur(1).xlsm
    17.1 KB · Affichages: 6

BEGEX

XLDnaute Nouveau
Bonjour BEGEX, bienvenue sur XLD, Dudu2,

Oui, voyez le fichier joint et cette macro :
VB:
Private Sub Worksheet_Change(ByVal Target As Range)
On Error Resume Next
If IsEmpty(Target) Or Application.CountIf(Evaluate(Target.Validation.Formula1), Target) Then Else MsgBox "Attention ce nom n'est pas dans la liste de référence...", vbInformation
End Sub
A+
Merci infiniment pour toutes vos réponses, merveilleux !
 

BEGEX

XLDnaute Nouveau
Bonjour,
Je reviens vers vous toujours pour le même problème.
Afin de faciliter la saisie sur la liste déroulante j'ai créé une formule trouvée sur le forum (https://www.excel-downloads.com/threads/liste-deroulantes-dynamiques-semi-automatiques.20066663/) du type :
=SI(A2<>"";DECALER(f_region;EQUIV(A2&"*";f_region;0)-1;;NB.SI(f_region;A2&"*");1);f_region).
Cela permet de faire une sorte de liste déroulante semi automatique.
Du coup la solution proposée ne fonctionne plus.
Existe-t-il une autre méthode ?
Merci de votre aide
Cdlt
 

job75

XLDnaute Barbatruc
Bonjour BEGEX,

La formule que vous indiquez ne pose aucun problème.

Il suffit de la nommer avec le nom Liste qu'on utilise comme formule de validation, voyez ce fichier (2).

A+
 

Pièces jointes

  • Classeur(2).xlsm
    16.2 KB · Affichages: 6

BEGEX

XLDnaute Nouveau
Bonjour BEGEX,

La formule que vous indiquez ne pose aucun problème.

Il suffit de la nommer avec le nom Liste qu'on utilise comme formule de validation, voyez ce fichier (2).

A+
Bonjour et pardon pour ma réponse tardive.
Cela fonctionne très bien, j'ai enfin résolu mon problème.
Merci beaucoup job75 pour toutes ces astuces et votre partage.
Merci également Dudu2 pour votre participation.
A bientôt
 

Discussions similaires

Statistiques des forums

Discussions
299 702
Messages
1 978 590
Membres
206 298
dernier inscrit
yannick451