Microsoft 365 INDEX EQUIV Plusieurs colonnes autre fichier

PhilKo

XLDnaute Nouveau
Je souhaite créer une feuille EXCEL pour un export de donné. Mes données entrantes (feuille Import) ayant toujours des colonnes avec les même en-têtes, mais pas forcément dans le même ordre, je souhaite que ma feuille Export , vienne chercher les données dans les colonnes imports.
Par exemple, dans la feuille export, en colonne C , "salaires de base",en ligne 2, je souhaite chercher dans la feuille import, la valeur de la ligne 2, colonne "Salaire de base", idem pour la colonne D, je cherche la valeur de l'en-tête de la feuille Import, etc... J'ai tenté cette formule avec les fonctions INDEX EQUIV :
=INDEX(Import!$C2:$CC2;;EQUIV(C$1;Import!$A$1:$DZ$1;0))
, cela fonctionne uniquement pour la colonne C, mais ne fonctionne pas pour ls autres colonnes, et ca fait 2 semaines que je galère.
 

Pièces jointes

  • Tableau exports copie.xlsx
    40.5 KB · Affichages: 1

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Philko, et bienvenu sur XLD,
Tout d'abord lisez notre charte ( Lien ) vous pourrez y lire :
Lorsqu’on rentre sur un fil, comme dans la vie de tous les jours, on est poli en disant « Bonjour ».
Je trouve, perso, que c'est un minimum qu'on ne devrait pas avoir à rappeler. :)

Pour votre souci, avec ce que j'ai compris, essayez :
VB:
=SIERREUR(INDEX(Import!$1:$1048576;LIGNE();EQUIV(C$1;Import!$A$1:$DZ$1;0));"")
 

Pièces jointes

  • Tableau exports copie.xlsx
    42.5 KB · Affichages: 8

Discussions similaires

Réponses
6
Affichages
614

Statistiques des forums

Discussions
312 534
Messages
2 089 383
Membres
104 152
dernier inscrit
sabalex