Impossible de nommer une formule

catdog

XLDnaute Junior
Bonjour,

Je suis adepte du nommage de formules depuis que je me suis rendu compte que cela pouvait influencer la réactivité ou le poids d'un fichier. :)

Quoi qu'il en soit, je souhaite nommer une formule, mais Excel ne me l'ajoute jamais dans la liste du gestionnaire de noms... et j'ignore pourquoi, car il n'y a aucun message d'erreur.:mad:

La formule est la suivante :
=SI(OU(GAUCHE($H2;2)="64";GAUCHE($H2;3)="633");"DP";SI(GAUCHE($H2)="2";"DI";SI(GAUCHE($H2)="6";"DF";SI(GAUCHE($H2)="7";"RF";SI(GAUCHE($H2)="1";"RI";"TECH")))))

En fonction des premiers caractères d'un compte, je souhaite indiquer un code pour les masses.
La formule est déjà saisie dans une cellule, et elle fonctionne parfaitement.

Quand je demande à créer un nouveau nom dans le gestionnaire de nom, je définis le nom (j'en ai tenté plusieurs au cas où), j'indique la feuille où le nom sera valide (ou pas), et je colle la formule préalablement copié dans la cellule (d'où je n'ai pas bougé avant d'appeler le gestionnaire de noms).

Mais je ne m'explique pas cette impossibilité sans message d'erreur... :(

Avez-vous déjà rencontré ce genre de cas ? Quelle solution avez-vous trouvé ?

Merci d'avance pour votre aide, o_O

Olivier.
 

job75

XLDnaute Barbatruc
Bonjour catdog,

En effet c'est très curieux.

J'ai pu remédier au problème en nommant gauch la formule =GAUCHE($H2)

Ensuite la formule :
Code:
=SI(OU(GAUCHE($H2;2)="64";GAUCHE($H2;3)="633");"DP";SI(gauch="2";"DI";SI(gauch="6";"DF";SI(gauch="7";"RF";SI(gauch="1";"RI";"TECH")))))
se laisse nommer sans difficulté.

Question de nombre de caractères ? La formule n'est pourtant pas très longue.
 

JCGL

XLDnaute Barbatruc
Bonjour à tous,
Salut Gérard,

Le passage des chiffres ou nombres en numérique permet le nommage


upload_2017-3-20_19-27-14.png


A+ à tous
 

job75

XLDnaute Barbatruc
Re,

Cela dit tu as tout à fait raison Jean-Claude, cette formule se laisse nommer :
Code:
=SI(OU(--GAUCHE($H2;2)=64;--GAUCHE($H2;3)=633);"DP";SI(--GAUCHE($H2)=2;"DI";SI(--GAUCHE($H2)=6;"DF";SI(--GAUCHE($H2)=7;"RF";SI(--GAUCHE($H2)=1;"RI";"TECH")))))
Edit : je viens de voir ton dernier post, tu as aussi converti GAUCHE, d'une autre façon.

Mais le mystère de la chose demeure.

A+
 

catdog

XLDnaute Junior
Bonjour à tous,

Merci pour votre aide...

Mais pour paraphraser le poète JCGL : il est où l'problème, il est où ?

Car si la solution a été trouvée, cela n'explique toujours pas pourquoi Excel refusait de nommer une formule qui fonctionne quand elle est saisie dans une cellule et sans aucun message d'erreur...

Bonne continuation à toutes et tous,
 

job75

XLDnaute Barbatruc
Bonjour catdog, Jean-Claude, le forum,

Autre découverte, la formule peut être nommée en utilisant VBA :
Code:
Sub test()
[A2].Select 'à cause des références relatives
ThisWorkbook.Names.Add "a", RefersToR1C1:=[A2].FormulaR1C1
End Sub
la formule ayant été préalablement entrée en A2.

Et la formule du nom "a" peut être modifiée manuellement : remplacer "64" par "65".

A+
 

Discussions similaires

Statistiques des forums

Discussions
312 877
Messages
2 093 155
Membres
105 642
dernier inscrit
ABDELMAJIDZIANI