Garder la mise en forme conditionnelle apres un tri [Résolu].

gigiwin

XLDnaute Occasionnel
Bonsoir à tous,

Mon classeur excel contient :
En C nom des fournisseurs,
en J, des réferences
en F et G des sommes.

J'ai atribué une MFC pour que si:
F>G couleur de fond bleu
F<G couleur de fond jaune

Jusque là pas de soucis, c'est aprés que cela se gatte....

Quand je fais un tri par la colonne J, les cellules colorés devraient être sur les ligne où il y 1 en colonne E, mais il y des ratés, les cellules qui sont colorées changent.

Que dois-je faire pour que cela ne se produise plus?

Merci
 

Pièces jointes

  • GIGI.xls
    38.5 KB · Affichages: 63
Dernière édition:

Misange

XLDnaute Barbatruc
Re : Garder la mise en forme conditionnelle apres un tri

Bonjour

Deux problèmes je pense :
tes mefc n'étaient pas bien entrées : en F2 on testait F29>G29 ou un truc du genre
il y a des cellules vides, des colonnes vides, les colonnes n'ont pas toutes la même taille ce qui est très dangereux quand on trie. Pour éviter cela mets ton tableau sous forme de liste, ça t'assure que "tout le monde suit"...
teste
 

Pièces jointes

  • Copie de GIGI.xls
    50 KB · Affichages: 56

gigiwin

XLDnaute Occasionnel
Re : Garder la mise en forme conditionnelle apres un tri

Bonjour Misange,

Mes excuses pour le retard de ma réponse.

Merci pour ta réponse, mais le hic s'est que mes autres colonnes ne sont pas vide, et que le fichier est partagé, les listes ne me conviennent pas.

J'ai trouvé la solution avec ces formules sur toute la colonne:
=SI(C2="5";F2>G2;" ") et =SI(C2="5";F2<G2;" ")

Merci tout de même d'avoir pris le temps d'étudier mon problème.

Bonne journée.
 
Dernière édition:

Discussions similaires

Statistiques des forums

Discussions
312 812
Messages
2 092 309
Membres
105 352
dernier inscrit
Djianik