XL 2019 garder en mémoire valeur cellule après effacement

Quicksland

XLDnaute Occasionnel
Bonsoir le forum ;)

Voici mon problème ...

En E2 la cellule additionne le résultat des cellule de la colonne D

mais lorsque j'efface B610,B1216,B1822,B2428,B3034 ect ...ma cellule E2 reviens a zero

est il possible de garder en mémoire cette valeur " exemple 25 " puis reprendre le décompte après effacement ?

Et en E6 menu déroulant " oui/non " lorsqu'il y a "oui le 1 de la colonne "D" s'affiche et quand c'est " non " la cellule reste vide

Et ceci dans les deux tableaux ;)

Merci a tous pour votre aide 👍
 

Pièces jointes

  • PLANNING 1.xlsm
    61.2 KB · Affichages: 6
Dernière édition:

fanch55

XLDnaute Barbatruc
Bonjour,
En E2 la cellule additionne le résultat des cellule de la colonne D
Non, c'est la somme de certaines cellules de la colonne D

mais lorsque j'efface B610,B1216,B1822,B2428,B3034 ect ...ma cellule E2 reviens a zero
Sur mon Pc, cela n'efface pas E2 ou K2 et c'est rassurant .

Et en E6 menu déroulant " oui/non " lorsqu'il y a "oui le 1 de la colonne "D" s'affiche et quand c'est " non " la cellule reste vide
La liste de validation ci-dessous est suffisante :
1650956497070.png

La colonne D est donc pseudo binaire, elle ne pourra n'avoir que 1 ou "" (0) .
En ce cas, la formule en E2 peut être =NB.SI(D: D;1)
[ non pas =NB.SI(E:E;"OUI") car incompatible avec E2 ]
la formule en D6 =SI(E6="OUI";1;"")

Classeur modifié en conséquence
 

Pièces jointes

  • PLANNING 1.xlsm
    58.5 KB · Affichages: 3

Quicksland

XLDnaute Occasionnel
Bonjour Fanch55

Merci pour ta réponse et ta correction 👍

j'ai un petit soucis en colonne K7 a K12 le 1 ne s'affiche pas :rolleyes:

par contre je souhaiterai pouvoir garder en mémoire E2 même si j'efface avec le bouton " semaine 1, 2 ,....
merci pour ta futur réponse :)
 

Pièces jointes

  • PLANNING 1.xlsm
    59 KB · Affichages: 1

fanch55

XLDnaute Barbatruc
j'ai un petit soucis en colonne K7 a K12 le 1 ne s'affiche pas
Normal, je n'avais pas propagé la formule ...

par contre je souhaiterai pouvoir garder en mémoire E2 même si j'efface avec le bouton " semaine 1, 2 ,....
E2 est une formule calculée automatique dépendante de la colonne D .
Quand voulez-vous calculer celle-ci ?
Sauvegarder le nombre en E2 ne vous dira pas à quelle semaine ou jour ce nombre s'appliquait ...
 

Pièces jointes

  • PLANNING 1.xlsm
    58.9 KB · Affichages: 1

Quicksland

XLDnaute Occasionnel
Bonjour Fanch55

Tout d'abord merci pour ton aide 👍

Effectivement après réflexion tu as raison ;)

Toujours dans l'optique d'amélioration du fichier ...

Serait il possible que quand dans la colonne "E" et "J' un "non " est appliquer " comme dans l'exemple " les cellules " B10:C10" "F13:H13 s'efface et que les cellules du dessous remonte ?

Merci pour ton aide 👍
 

Pièces jointes

  • PLANNING 3.xlsm
    80.9 KB · Affichages: 0

Discussions similaires