XL 2016 Formule pour calculer un index et la date de la précédente relève pour un suivi des consommations

7outils

XLDnaute Nouveau
Bonjour à tous,

Après avoir ramé pendant des jours, je me rapproche de vous afin de m'aider.

Dans le cadre d'un suivi des consommations J'ai:
  • Colonne A :la date des relevés
  • Colonne B : le nom du site relevé
  • Colonne C: Le type de compteur
  • Colonne D: L'index relevé
Dans la colonne E je souhaiterais avoir la date de la précédente relève pour le site en question et pour le compteur en question (donc deux critères) et dans la colonne F je souhaiterais trouver l'index de cette date F.

Je vous joint un fichier exemple pour mieux illustrer mon problème.

Merci à tous pour avance et bonne journée
 

Pièces jointes

  • Suivi des consommations.xlsx
    15.4 KB · Affichages: 5
Solution
Bonjour à tous,

par formule matricielle
VB:
=SIERREUR(INDEX($A$4:$A$18;GRANDE.VALEUR(SI(($A$4:$A$18<$A4)*($B$4:$B$18=$B4)*($C$4:$C$18=$C4);LIGNE($A$4:$A$18)-3);1));"")
Code:
=SIERREUR(INDEX($D$4:$D$18;EQUIV($B4&$C4&$E4;$B$4:$B$18&$C$4:$C$18&$A$4:$A$18;0));"")
Code:
=SI($E4<>"";D4-F4;"")
copier vers le bas

JHA

JHA

XLDnaute Barbatruc
Bonjour à tous,

par formule matricielle
VB:
=SIERREUR(INDEX($A$4:$A$18;GRANDE.VALEUR(SI(($A$4:$A$18<$A4)*($B$4:$B$18=$B4)*($C$4:$C$18=$C4);LIGNE($A$4:$A$18)-3);1));"")
Code:
=SIERREUR(INDEX($D$4:$D$18;EQUIV($B4&$C4&$E4;$B$4:$B$18&$C$4:$C$18&$A$4:$A$18;0));"")
Code:
=SI($E4<>"";D4-F4;"")
copier vers le bas

JHA
 

Pièces jointes

  • Suivi des consommations.xlsx
    16.6 KB · Affichages: 9

7outils

XLDnaute Nouveau
Bonjour à tous,

par formule matricielle
VB:
=SIERREUR(INDEX($A$4:$A$18;GRANDE.VALEUR(SI(($A$4:$A$18<$A4)*($B$4:$B$18=$B4)*($C$4:$C$18=$C4);LIGNE($A$4:$A$18)-3);1));"")
Code:
=SIERREUR(INDEX($D$4:$D$18;EQUIV($B4&$C4&$E4;$B$4:$B$18&$C$4:$C$18&$A$4:$A$18;0));"")
Code:
=SI($E4<>"";D4-F4;"")
copier vers le bas

JHA
Merci beaucoup JHA ! je suis vraiment très surpris, même en 1 mois je suis incapable de sortir une telle formule franchement chapeau !!
 

Discussions similaires

Réponses
6
Affichages
668

Statistiques des forums

Discussions
313 193
Messages
2 096 080
Membres
106 490
dernier inscrit
fabintou