XL 2010 Explication d'une formule

dela

XLDnaute Nouveau
Bonjour,
J'ai besoin de votre aide svp afin de comprendre une formule.

A la suite d'une extraction de plus de 8000 lignes, j'avais besoin d’étaler toute une famille sur une même ligne afin de créé par la suite un publipostage, a chaque fois tous les membres d'une famille devaient se retrouver sur la même lignes que la référence unique qui leurs est attribués (qui appairaient toujours en 1er).

On m'a communiqué une formule qui marche a merveille. Je copie les références dans une deuxième feuille et je supprime les doublons. Ensuite j’écris la formule en B2 que je copie ensuite sur toutes les lignes.

Pouvez m'aider a comprendre cette formule svp, pour la modifier si besoin et surtout pour approfondir mes connaissances. Ci-joint un nouveau tableau.

Merci beaucoup.
Code:
=SI(NB.SI(Feuil1!$A$2:$A$70;$A2)<ENT((COLONNE()+1)/3);"";INDEX(Feuil1!$B$2:$Y$70;EQUIV($A2;Feuil1!$A$2:$A$70;0)+ENT((COLONNE()-2)/3);1+MOD(COLONNE()-2;3)))
 

Pièces jointes

  • extraction avec code.xlsx
    11.1 KB · Affichages: 31

Discussions similaires

Réponses
9
Affichages
256
Réponses
8
Affichages
356

Statistiques des forums

Discussions
312 890
Messages
2 093 352
Membres
105 696
dernier inscrit
FrancisR