erreur de calcul d'une formule ??

  • Initiateur de la discussion JJ
  • Date de début
J

JJ

Guest
Re bonjour,
la formule donnée par Monique pour l'intervalle marche super bien (pour une plage)
Je l'ai adaptée à une colonne et le résultat est faux , pourquoi? je ne comprends pas
je joins l'exemple
JJ [file name=erreur_20060501102545.zip size=2045]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/erreur_20060501102545.zip[/file]
 

Pièces jointes

  • erreur_20060501102545.zip
    2 KB · Affichages: 16

Monique

Nous a quitté
Repose en paix
Bonjour,

Tu as un mélange de valeurs numériques et de texte
A1 contient un nombre,
A2:A7 et A11 contiennent du texte

Tu peux essayer :
=SI(SOMME(($A$2:$A$50*1=$A$1*1)*1)=0;'-';LIGNE()-MAX(SI($A$2:$A$50*1=$A$1*1;LIGNE($A$2:$A$50)))-1)

Pour le message où tu fais une moyenne,
pourquoi tu ne la fais pas (fichier d'hier)
en ligne 2 ?
 

andré

XLDnaute Barbatruc
Salut,

Les valeurs en A2:A13 sont en format texte, bien que ce format ait été modifié en Standard, mais sans revalider les données.

Cela se remarque immédiatement en voyant des 0 devant certains nombres.

Tapes 1 dans une cellule et copie cette valeur.
Sélectionnes A2:A13 et fais un collage spécial multiplication.

La formule matricielle renvoie 6, ce qui est exact.

Â+
 
J

JJ

Guest
Bonjour Monique et merci, je n'avais pas vu les cellules texte.

question simple pour toi: Dans ta formule matricielle :
{=si(nb.si(A$5:G5;I$5)=0;'-';ligne()-max(si(A$5:G5=I$5;ligne(A$5:G5))))}
(plage par ex A$5:G5)
que dois-je laisser dans la formule pour enlever le test =0 =>'-' , car ce cas ne peut exister car je suis en fin de tableau?
(j'ai tjrs une erreur de parenthèse ou de critère quand je veux la bidouiller)
J'a voulu commencer par :{=si(ligne()-max... pas valable
merci
JJ
 
J

JJ

Guest
Monique, merci encore !
'Notre' travail est presque achevé, (une moyenne à calculer avec une macro), si tu veux, je t'enverrai le fichier , tu me diras ce que tu en penses pour un amateur en formules (je ne travaille qu'en VBA)
Le fichier que je te transmettrai (si tu le souhaites bien sûr) est réel et basé sur un hstorique loto de 4356 tirages avec complémentaire.
Quant à mes calculs (moy, ecart, combinaisons,...)tu me diras !

Bon lundi
JJ
 

Discussions similaires

J
Réponses
0
Affichages
873
J

Statistiques des forums

Discussions
313 320
Messages
2 097 137
Membres
106 848
dernier inscrit
toufk