XL 2013 création total de cellule (SI) je pense

Gae1

XLDnaute Nouveau
Bonjour à tous



Et il possible d’avoir le total des nombres qui se trouverons dans les cellules de la colonne B entre B 3 et B 33 qui seront ou vert ou jaune ou orange ou rouge

Selon leurs résultats qui sera différent à chaque foi

(EX pas le nombre de cellules jaune mais le total de la quantité des cellules qui seront en jaune ou vert ou orange ou rouge)

En vert de B3 à B33 résultat en D35

En Jaune de B3 à B33 résultat en E35

En Orange de B3 à B33 résultat en F35

En Rouge de B3 à B33 résultat en G35

Tout en gardant la couleur de chacune des cellules en 35

J’espère que mon explication et logique

Merci d’avance en espérant que cela soit possible J
 

Pièces jointes

  • tabac finition.xlsx
    13 KB · Affichages: 7

chris

XLDnaute Barbatruc
Bonjour
Sauf à coder, la couleur n'est pas utilisable dans une somme

Ce que tu as fait en D35 et E35 est correct
on peut utiliser
=NB.SI(B3:B33;7) en F35 et
=SOMMEPROD((B3:B33>=8)+(B3:B33<=10)) en G35
 
Dernière édition:

gbinforme

XLDnaute Impliqué
Bonjour,
j'espère avoir compris ton explication et je t'ai mis en ligne 36 le total avec la formule :
VB:
=SOMMEPROD(($B$3:$B$33>=GAUCHE(D34;1)*1)*($B$3:$B$33<=DROITE(D34;2)*1)*$B$3:$B$33)
 

Pièces jointes

  • tabac finition.xlsx
    12.9 KB · Affichages: 3

chris

XLDnaute Barbatruc
RE

je pensais ne pas avoir posté mon message car j'avais un doute (mais j'ai du cliquer par erreur)

En effet est-il utile d'exclure 0 et au delà de 10 ?

En utilisant les seuils on peut simplifier un peu
 

Pièces jointes

  • tabac finition2.xlsx
    13.9 KB · Affichages: 2

Gae1

XLDnaute Nouveau
Bonsoir Chris un grand merci à toi
pour ton aide pour la couleur je vais juste mettre les couleurs correspondante
petite question comment lie ton la formule pour que je puisse la comprendre et pour quoi gauche et droite aussi ? merci
Gae
 

Discussions similaires

Réponses
9
Affichages
444
Réponses
2
Affichages
321

Statistiques des forums

Discussions
313 283
Messages
2 096 810
Membres
106 751
dernier inscrit
Souleymani