XL 2010 création d'une formule

majestic34

XLDnaute Nouveau
Bonjour
j'ai besoin d'un coup de main de votre part je vous explique tout dans la suite du descriptif j'ai joint un fichier pour illustrer
merci a vous pour vos conseils et aides

Dans la colonne B on trouve les cases suivantes :
Roulement = roulement officiel si aucun changements
M officiel = Matin
A officiel = Apres midi
N officiel = Nuit
FLO = congés
RTT = congés
E24 = congés
M modif = si changement dans la ligne 22
A modif = si changement dans la ligne 22
N modif = si changement dans la ligne 22
F10 = Formation
R = Repos
Dans les colonnes de BS -BT - BU - BV - BW - BX on retrouve le nombre de jours ( matin etc...)

Exemple de ce que je voudrais faire mais je n'arrive pas à trouver la bonne Formule.
Si dans la ligne 22 colonne G "G22" normalement je travaille du matin officiel mais on me
fait faire un remplacement d'après-midi donc en "G22" j'écris " A" ce qui incrémente "G18" à
1 et en "BT10" aussi mais ce que je n'arrive pas à faire c'est enlever le 1 en "G11" et "BS10"
Comment faire pour dire que les lignes "B14" à "B21" sont prioritaire sur les lignes "B11" à "B13"

exemple 1 : si en "K22" je mets "E24" donc en "BV10" j'aurais 1 et en "BU10" j'aurais 11

exemple 2 : si en "T22" je mets "A" donc en "BU10" j'aurais 11 et en "BT10" j'aurais 13
 

Pièces jointes

  • Planning formule.xlsm
    46.7 KB · Affichages: 3

Lu76Fer

XLDnaute Occasionnel
Bonjour,
Voici ce que vous pouvez modifier dans votre exemple :
VB:
'En cellule "G11" :
=NB.SI(G10;"M")
'A remplacer par :
=NB.SI(G$10;SI(ESTVIDE(G$22);"M";G$22))
Le signe $ n'est pas obligatoire mais il permet d'avoir une référence absolue plutôt que relative ...
Cela facilité le copier-coller de fonction lorsqu'on 'étend' celle-ci.
A appliquer partout bien-sûr ...
 

Discussions similaires

Réponses
3
Affichages
107

Statistiques des forums

Discussions
313 204
Messages
2 096 208
Membres
106 530
dernier inscrit
miomi98