Autres Copie de ligne à partir d'un code

Moreno076

XLDnaute Impliqué
Bonjour à tous,

Dans le fichier ci-joint il y a plusieurs onglets avec les mois de l'année.

Je souhaiterais qu'en rentrant un code dans la colonne C de chaque mois, ca recopie la ligne correspondant du code qui se trouve dans l'onglet SC (D à W). Juste copie des valeurs.

Le fichier est sous excel dans ce post mais c'est google sheet.

Merci pour votre aide.
 

Pièces jointes

  • Copie de Heures (1).xlsx
    210.2 KB · Affichages: 2

job75

XLDnaute Barbatruc
Bonjour Moreno076, le forum,

Je ne comprends rien à vos formules alambiquées.

Voyez le fichier joint, le mois de Février et les cellules colorées en jaune :

- formule très simple en D10, copiée sur les autres cellules :
Code:
=SIERREUR(INDEX(SC!D:D;EQUIV($C10;SC!$C:$C;0));"")
- format heure qui masque les valeurs zéro h:mm;;

A+
 

Pièces jointes

  • Copie de Heures.xlsx
    449.3 KB · Affichages: 3

Lu76Fer

XLDnaute Occasionnel
Bonjour Moreno076, le forum,

Je ne comprends rien à vos formules alambiquées.

Voyez le fichier joint, le mois de Février et les cellules colorées en jaune :

- formule très simple en D10, copiée sur les autres cellules :
Code:
=SIERREUR(INDEX(SC!D:D;EQUIV($C10;SC!$C:$C;0));"")
- format heure qui masque les valeurs zéro h:mm;;

A+
Bonjour Job75,
Je suppose que ces formules alambiquées ne fonctionne qu'avec Google Sheet car les noms de fonctions n'existent pas sous Excel.
De plus, y a t'il vraiment tous les éléments pour répondre même pour un spécialiste de Google Sheet, je n'en suis pas sûr ...
En tout cas si ça marche c'est l'essentiel ...
 

Moreno076

XLDnaute Impliqué
Bonjour job75.

Oui effectivement ça fonctionne aussi ! et la formule dans chaque cellule est peut-etre plus simple que modifier la problème ligne selon la longueur du tableau.
Petit plus aussi pas de différence entre miniscule et majuscule concernant à l'autre tableau.

Merci beaucoup.

Par contre je viens de m'apercevoir d'un soucis dans la suite des colonnes du tableau que je n'avais pas transmis. Pour les lignes vides et pas que d'ailleurs, ca me rempli les colonnes Z AC AD AK AL alors ca devrait être vierge car pas de valeur. J'ai mis en rouge dans l'onglet janvier les valeurs qui sont bonnes dans les colonnes concernées. Les autres valeurs de ces colonnes ne devraient pas être présentes.

Merci
 

Pièces jointes

  • Heures 3 (1) (2).xlsx
    158.6 KB · Affichages: 1
Dernière édition:

Discussions similaires

Statistiques des forums

Discussions
313 265
Messages
2 096 665
Membres
106 703
dernier inscrit
cbl