XL 2013 Conflit fonctionnement de 2 userform sur un même classeur

cfaure

XLDnaute Nouveau
Bonjour à tous,

Dans le fichier ci-joint voici mon problème:

Ma userform1 de la feuil "CRM" fonctionne et pas de problème = La combobox liste déroulante "sélectionner le nom du contact" a pour source la colonne C de la feuil "CRM" et je vois bien apparaitre les données quand je clique sur le bouton de séléction.

Ma userform2 de la feuil "HEBDO" ne fonctionne pas comme je voudrais: lorsque je souhaite "lancer" ma userform, un message d'erreur "erreur d'exécution '2147024809(80070057) " apparait.
J'ai par hasard changé le nom de ma UserForm_Initialize() en UserForm2_Initialize() dans le vba.
cela me permet de lancer ma userform 2, mais dans ma combobox liste déroulante "sélectionner le nom du contact" (source = colonne C de la feuil "CRM" également) quand je souhaite sélectionner un nom, aucun contact n'apparait...

Je suis complètement bloqué pourriez-vous m'aider?
Ci-joint le fichier zippé avec le code

Par avance merci,
Cédric
 

Pièces jointes

  • Classeur1 userfrom à envoyer.zip
    275.1 KB · Affichages: 23
  • Classeur1 userfrom à envoyer.zip
    275.1 KB · Affichages: 30

roro69

XLDnaute Impliqué
Re : Conflit fonctionnement de 2 userform sur un même classeur

Bonjour
Dans ta procédure de lancement de ton userform tu boucle sur 26 textbox alors que tu en a que 3
Il faut changer ta boucle
For i = 1 to 26
EN
For i = 1 to 3
A++
 

Paf

XLDnaute Barbatruc
Re : Conflit fonctionnement de 2 userform sur un même classeur

Bonjour,

je n'ai rien compris à l'histoire du renommage, mais dans la userform2 on tente de traiter 26 textbox alors qu'il n'y en a que 3.

A+

Edit : bonjour roro69
 

cfaure

XLDnaute Nouveau
Re : Conflit fonctionnement de 2 userform sur un même classeur

Bonjour Paf et Roro

Merci pour vos réponses. En effet j'ai volontairement enlever des textbox pour tenter de réduire la taille du document afin de vous l'envoyer...
En fait ce n'est pas les textsboxs qui me posent problème. Je vais essayer d'être plus clair:
- la combobox1 "liste déroulante" de ma userform1 fonctionne à mon goût, c'est à dire qu'elle laisse apparaître les données lorsque j'appuie sur le bouton de séléction. La source est la colonne "C" de ma feuil "CRM".

- la combobox2 "liste déroulante" de ma userform2 ne fonctionne pas , c'est à dire qu'elle ne laisse pas apparaître les données lorsque j'appuie sur le bouton de sélection. La source est également la colonne "C" de ma feuil "CRM".

Donc est-ce un problème d'interférence entre les deux Userform ou Combobox?
Est-ce autre chose...?
Je suis bloqué :(

merci pour vos retours et votre aide précieuse,

Cédric
 

Statistiques des forums

Discussions
300 874
Messages
1 987 963
Membres
210 032
dernier inscrit
pbellin06