Conditionnel et Moyenne gérant les Coeficients

SHAG

XLDnaute Nouveau
Dans une feuille de calcul de moyenne de notes scolaires avec Coeficients
J'ai la fonction suivante:

=SI(NBVAL(C11:N11)=0;'';SI(NB(C11:N11)<1;'Abs';SI(MAXA(C11:N11)>20;'Erreur';(MOYENNE(C11:H11)+MOYENNE(I11:N11)*2)/3)))

Qui doit:

- Ne rien afficher si rien d'inscrit dans (C11:N11)
- Ecrire Absent si 'Abs' est écrit SANS notes
- Afficher 'Erreur' dans la cellule si la valeur est supérieur à 20
- Faire la moyenne en tenant compte que: (C11:H11)=Coef 1 et (I11:N11)=Coef 2
- Si 1 note dans (C11:H11) et ABS dans (I11:N11); afficher la note
- Si 1 note dans (I11:N11) et ABS dans (C11:H11);afficher la note
- Si 1 note dans (C11:H11) et pas de note dans (I11:N11); afficher la note
- Si 1 note dans (I11:N11) et pas de note dans (C11:H11);afficher la note


Les 4 premiers points fonctionnent bien, mais les 4 derniers ne fonctionnent pas.
J'ai essayer avec la fonction ET, mais ça me renvoit des messages d'erreur et j'ai l'impression que ça 'allourdie' pas mal la fonction...
:(

j'ai essayé dans cette direction:

=SI(NBVAL(C8:N8)=0;'';SI(MAXA(C8:N8)>20;'Erreur';SI(ET(T(C8:H8)='Abs';NBVAL(I8:N8)>=1;MOYENNE(I8:N8));SI(ET(T(I8:N8)='Abs';NBVAL(C8:H8)>=1;MOYENNE(C8:H8));(MOYENNE(C8:H8)+MOYENNE(I8:N8)*2)/3))))

mais ça merdouille.... :(

Si quelqu'un pouvait m'apporter ses lumières, ça m'aiderait beaucoup.
 

CBernardT

XLDnaute Barbatruc
Bonjour Shag,

Comme on le dit souvent, un petit fichier vaut mieux qu'un long discours.
Donc si tu pouvais joindre un fichier de 50 Ko max zippé sans accent ni caractère spécial dans le titre cela faciliterai grandement la recherche de la solution.

Cordialement

Bernard
 

SHAG

XLDnaute Nouveau
Oups...effectivement, ça serait plus clair... :whistle:

Voici donc en pièce jointe le fichier Excel concerné.

Merci de ton aide. [file name=BEPA1VENTEG6.zip size=7945]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/BEPA1VENTEG6.zip[/file]
 

Pièces jointes

  • BEPA1VENTEG6.zip
    7.8 KB · Affichages: 27

CBernardT

XLDnaute Barbatruc
Re Shag,

Désolé, mais j'ai du m'absenter !

Le petit fichier est parfait et j'ai à peu près tout compris !

Mais, car il y a un mais ???

Si je prends la ligne 9, le 11 en colonne C correspond à un contrôle. Pourquoi un Abs en colonne D et rien sur les lignes des autres élèves ?

De même en ligne 13, le 12 en colonne C correspond à un contrôle. Le 11 en colonne I, correspond à un contrôle à coefficient 2. Pourquoi un Abs en colonne J et des vides sur les autres élèves ?

Pourquoi en ligne 7, 11 et de 11 à 28 pas d'Abs ?

Sans être très accro à l'adage de Boileau : 'Ce qui se conçoit bien s'énonce clairement....', peux-tu commenter l'absence de note pour certains élèves non absents ou des Abs tous seuls ?

Cordialement

Bernard
 

SHAG

XLDnaute Nouveau
CBernardT-> Merci de tenter de m'aider, je n'ai pas été très clair: en fait, ces notes sont juste là pour tester la formule avec différents cas possibles.
Sinon, les 6 premières colonnes blanches de notes sont censées être coefficientées 1 et les 6 colonnes suivantes vertes sont censées être coefficientées 2.

Gael-> Superbe ! ça maaaarche ! :silly: Grand merci. ;)



Merci à vous deux.

Problème résolu.
 

Discussions similaires

Réponses
18
Affichages
950

Statistiques des forums

Discussions
312 913
Messages
2 093 534
Membres
105 751
dernier inscrit
fred13340