XL 2016 combinaison de conditions

fm1616

XLDnaute Nouveau
Bonjour.
Je cherche une formule qui me permette de calculer une valeur qui dépend des valeurs des cellules C108 et C110 dans mon tableur.
Problème : je n'arrive pas à combiner les 2 conditions.

Voici les données :
CONDITION 1
si C110 < 10% alors 0
si 10% <= C110 < 12% alors 0.1%*C108
si 12% <= C110 < 14% alors 0.2%*C108
si 14% <= C110 < 16% alors 0.3%*C108
si C110 >= 16% alors 0.4%*C108

CONDITION 2
si C108 < 120000 alors 0
si 120000 <= C108 < 130000 alors 0.8*RESULTAT CONDITION 1
si 130000 <= C108 < 140000 alors 0.9*RESULTAT CONDITION 1
si 140000<= C108 < 150000 alors 1*RESULTAT CONDITION 1
si CA >= 150000 alors 1.1*RESULTAT CONDITION 1

Merci d'avance pour votre aide.

Cordialement.


User
 

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour FM,
( au lieu de mettre un joli logo, il eût été préférable de mettre un petit fichier test ;)
En PJ un essai avec une possibilité parmi d'autres :
VB:
Condition 1 :
=SI($C$110<10%;0;SI($C$110<=12%;0.1%*C108;SI($C$110<=14%;0.2%*C108;SI($C$110<=16%;0.3%*C108;0.4%*C108))))
Condition 2 :
=SI($C$108<120000;0;SI($C$108<130000;0.8*$C$113;SI($C$108<140000;0.9*$C$113;SI($C$108<150000;$C$113;1.1*$C$113))))
A bien vérifier toutes les combinaisons mais le principe est là.
 

Pièces jointes

  • fm.xlsx
    8.4 KB · Affichages: 1

AtTheOne

XLDnaute Accro
Supporter XLD
Bonjour à toutes & à tous, bonjour @fm1616 et @sylvanu
Allez, j'y vais de ma proposition sans fonctions SI imbriquées :
Pour la première condition :
=CHOISIR(EQUIV(C110;{0;0,1;0,12;0,14;0,16});0;0,1%;0,2%;0,3%;0,4%)*C108
Pour la deuxième :
=CHOISIR(EQUIV(C108;{0;120000;130000;140000;150000});0;0,8;0,9;1;1,1)*Résultat_Condition_1
(j'ai nommé la cellule contenant le résultat de la 1ère condition "Résultat_Condition_1")

Voir fichier joint

A bientôt
 

Pièces jointes

  • combinaison de conditions.xlsx
    9.4 KB · Affichages: 0

Discussions similaires

Statistiques des forums

Discussions
312 561
Messages
2 089 672
Membres
104 252
dernier inscrit
dbsromaric