Combien de fois un mot apparait dans plusieurs feuilles ?

slashouille

XLDnaute Nouveau
Bonjour, j'ai un tout petit problème pour vous professionnels d'Excel :p

Voilà j'ai un fichier excel qui contient plusieurs feuilles !

j'aimerai créer une feuille qui comptabilise combien de fois on retrouve le nom "thomas" par exemple dans toutes les feuilles !

j'ai essayé la fonction nb.si mais celle-ci ne marche que dans la même feuille.
La recherche ne s'effectue pas sur l'ensemble des feuilles :(:(:(

Vous avez une solution ? Si mon explication est obscure n'ez pas !

voici un petit exemple :)
 

Pièces jointes

  • test.xls
    22.5 KB · Affichages: 166
  • test.xls
    22.5 KB · Affichages: 145
  • test.xls
    22.5 KB · Affichages: 151

TheLio

XLDnaute Accro
Re : Combien de fois un mot apparait dans plusieurs feuilles ?

Hello,
et bienvenue sur Xld
Il y a certainement plus futé, mais en nommant tes tableaux > Tablo_1 Tablo_2 ...
=NB.SI(Tablo_1;"thomas")+NB.SI(Tablo_2;"thomas")...
Tu devrais trouver un résultat
A++
TheLio
Edit: Attention à l'orthographe, aux majuscules, aux espaces
 
Dernière édition:

BOISGONTIER

XLDnaute Barbatruc
Repose en paix
Re : Combien de fois un mot apparait dans plusieurs feuilles ?

Bonjour,


=SOMMEPROD(NB.SI(INDIRECT("'"&D2:D4&"'!A1:O13");A2))

JB
 

Pièces jointes

  • MatCompte3D.xls
    36.5 KB · Affichages: 282
  • MatCompte3D.xls
    36.5 KB · Affichages: 244
  • MatCompte3D.xls
    36.5 KB · Affichages: 237

slashouille

XLDnaute Nouveau
Re : Combien de fois un mot apparait dans plusieurs feuilles ?

Merci pour ce lien ! :) La formule marche bien !

Mais comment faire pour ne pas avoir à écrire le nom des feuilles à la main ??? Que excel puisse récupérer les données sans avoir à nommer chaque feuille ! j'en ai 49 !!!!! Mais imaginons que j'en ai 1000000 ça serai impossible à gérer !

Merci d'avance les experts ;)
 

BOISGONTIER

XLDnaute Barbatruc
Repose en paix
Re : Combien de fois un mot apparait dans plusieurs feuilles ?

Bonjour,

Dans la PJ du post précédent, il y a une fonction perso matricielle qui donne les noms de tous les onglets =nomsonglets()

Code:
Function NomsOnglets()   ' fonction matricielle
   Dim temp()
   ReDim temp(1 To Sheets.Count)
   j = 1
   For i = 1 To Sheets.Count
      temp(j) = Sheets(i).Name
      j = j + 1
   Next i
   NomsOnglets = Application.Transpose(temp)
End Function

JB
 

slashouille

XLDnaute Nouveau
Re : Combien de fois un mot apparait dans plusieurs feuilles ?

Merci beaucoup ! ça m'a pas l'air simple ! Je suis très novice en excel masi avec tout ces compléments je vais essayé de comprendre ! Je reviendrais vers toi si j'ai un soucis !


Merci pour votre rapidité ;)
 

BOISGONTIER

XLDnaute Barbatruc
Repose en paix
Re : Combien de fois un mot apparait dans plusieurs feuilles ?

-Alt+F11
-InsertionModule

Function NomsOnglets() ' fonction matricielle
Dim temp()
ReDim temp(1 To Sheets.Count)
j = 1
For i = 1 To Sheets.Count
temp(j) = Sheets(i).Name
j = j + 1
Next i
NomsOnglets = Application.Transpose(temp)
End Function


-Sélectionner G5:G8
=nomsonglets()
Valider avec Maj+Ctrl+entrée

JB
 

alabri

XLDnaute Nouveau
Re : Combien de fois un mot apparait dans plusieurs feuilles ?

bojour à tous
moi j'ai fait ce type de formule et de module et pour une raison bizarre la réponse est supérieure au nombre réel
j'ai plusieurs onglets et plusieurs personnes peuvent etre indiquée dans chaque onglet.
je veux compter le nombre de fois qu'une personne est inscrite
et le résultat est bizarre, car une personne est intervenu 7 fois et le résultat est 15. j'avoue que je n'y comprend rien.
ma formule de recherche: =SOMMEPROD(NB.SI(INDIRECT("'"&J5:J25&"'!F23:I34");A4)) validée par CTRL ALT ENTREE
J5:J25 nom des onglets
F23:I34 cellule de chaque onglet ou peuvent etre inscrit le nom des personnes intervenantes
A4 nom de la personne recherchée
ici module
Function NomsOnglets() ' fonction matricielle
Dim temp()
ReDim temp(1 To Sheets.Count)
j = 1
For i = 1 To Sheets.Count
temp(j) = Sheets(i).Name
j = j + 1
Next i
NomsOnglets = Application.Transpose(temp)
End Function
et de J5 à J25
=NomsOnglets() validée par CTRL ALT ENTREE
j'ai l'impression que le calcul me double le nombre réel
voila mon problème.
merci d'avance
 
Dernière édition:

Discussions similaires

Réponses
16
Affichages
740

Statistiques des forums

Discussions
312 907
Messages
2 093 472
Membres
105 740
dernier inscrit
Mln